Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
have a ford focus 2.0 sohc motor just rebuilt it but now having troubles taking off it chugs alot when giving gas and idles rough. once you get going 40 + it clears up once it does that you can stop at red light and almost cant feel car idle its so smooth.. But when I got on highway 85- 95 mph and it started to chug and check engine light came on and flashed till i dropped to about 70 mph then went out.. I feel it might be fuel filter/pump just want to see what you guys thought befor i start tearing tank out of car.. thanks
 

·
Premium Member
Joined
·
21,250 Posts
Did you change the fuel filter recently? That's a lot easier than changing the fuel pump. Check to see if you have any DTC codes stored using the odometer trick, or go by a parts store and have them run the codes for you. Don't buy anything without checking with us first. Also, write down the number of the code and check it on here. Our descriptions are a little better than theirs are.
 

·
Registered
Joined
·
119 Posts
Discussion Starter #4
something desided to break on motor tonight so i have to find and repair it befor getting back to cutting out problem.. new fuel filter didn't change anything but alot of dirt color gas came out of old filter.. did turn key on and pushed the knob thing in and my dad said it didn't really shoot out of it real fast. need to rent fuel pressure gauge to make sure befor new pump.. i have a scan gauge but only works if light is on how do you get codes with no light on?
 
1 - 4 of 4 Posts
Top