Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
303 Posts
Discussion Starter #1
[scratch] So i just put 4 tweeters in.... wired each one to each speaker..... did the front two tuesday...got the back done today.....cruisin down the road testing them out...all of a sudden the right side loses all its sound!!! its the stock headunit with a rca converter in the back. Any ideas?
 

·
Registered
Joined
·
488 Posts
check your wiring to the speakers... sounds like youve got a wire that has came loose and grounded out against the body or anything metal for that matter... which will short the whole channel (the right side of the car)

check your wiring for loose connections and make sure the RCA converter isnt touching anything bare metal that can cause problems

-AcId-
 

·
Registered
Joined
·
90 Posts
I was trying to put some in my fo-fo but at least mine doesnt have any speakers on rear deck so I tried conecting them to the conecter on the rear door. I acsodently connected them the wrong way and the whole radio went out and un hooked and its fine.

Question for you is how would I install new speakers or more speakers and what about this RCA converter thing. It sound like something I could use.... Does it have inputs and outputs?
 

·
Registered
Joined
·
303 Posts
Discussion Starter #4
The rca converter is so you can install an amp with your stock radio...I tapped into the rear speakers from the back of the radio and then ran the rca wires from the converter to my amp.
 
1 - 4 of 4 Posts
Top