Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
149 Posts
Discussion Starter #1
In spirited driving, on a hard 1st to 2nd shift, my car sometimes gives up.


What I mean by this is sometimes after i slam it into 2nd and pop the clutch and press the gas(all at the same time), it feels like the car stalls out, but it doesnt. It drops to about 3k rpm, and just does nothing. No feedback from anything. My foot is still firmly pressing all the way down on the gas pedal. Just nothing happens. After about a second or 1.5, it makes up its mind and takes off again.

I previously thought this was due to the shipoopi RMM, which I replaced with the JBR RMM, but it still does it. I dont know if its user error( me popping the clutch too soon), or something acutally wrong. It happens maybe 1 out of 5 times during hard driving. Just would like to know if anyone has experienced this, or knows anything about it. I appreciate it.

2014 SE 5-speed hatchback.
 

·
Registered
Joined
·
324 Posts
I've experienced this before. I'm not sure what causes it, but it seems related to traction control.
I had this happen to me at an autox event. I had forgotten to turn off TC. I made sure it was off for my subsequent runs; it didn't happen again. I've never had this happen when I have TC off; only when on.
 

·
Registered
Joined
·
81 Posts
+1 for TC... The car pretty much falls on its face. Kinda scary the first time it happened. Same thing happens when I'm accelerating over bumps. The TC is super sensitive.
 

·
Registered
Joined
·
149 Posts
Discussion Starter #5
Thats really weird.

TC was actually my first guess, but because the light never popped on I figured it wasnt related.

So solution is to take TC off all the time then. Gotcha. Appreciate it fellas.
 
1 - 5 of 5 Posts
Top