Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Max8
Joined
·
2,858 Posts
Discussion Starter #1
Ok so the spell on my car didn't wokr at all; the gipsy curse is back[clap] Now it appears itself in the way of making my car feel like a wimp and taking away like 4 miles per gallon on average[V] I don't now what is it now. It doesn't feel dead, just like if my car was sick, not performing as well as a couple weeks. No MIL, spark plugas, oil, oil filter, air filter cleaned and clean gasoline all done less than 1000 miles ago so I don't know. I have a feeling that this is just the tip of the iceberg, like just an announcement of something really bad about to happen[xx(] It might be due that my car has the name of a dead drug dealer and he doesn't like that. I don't know, I take really good care of my car, always put premium stuff in it and perform all services by myself to assure quality work but now, I'm about to give up[dunno] I might have to sell my soul to the devil[read] [deviltail] or this car is going to kill me someday. Every time I have plans of improvement for my car something to fix comes in the middle and that just makes me feel like a horsekick in the balls[nutkick]. I'm getting sick of this [rant]

Well, enough of the rant. Now let's go to the facts. About a week ago I started to notice a little mpg variation (less mpg to be precise) from what I used to get. Normal driving, mostly freeway miles and some city driving. My driving habits haven't change at all. Also I feel my car with less power (imagine that, my car is as slow as a snail and now with less power[:(] !!) through out all gears (atx). I mean, I accelerate and I don't feel the same as before, the car goes slower. I floor it and it doesn't respond as well. I don't hear any weird sounds nor I feel anything else wrong. I was thinking that it might be spark plugs, I've always used NGK laser platinum but this last service I went with Autolites 104's, but that was like 400 miles ago; the problem should have been there right away... Am I correct? So I don't know. I just feel like using brute force and kick the car all over[gunfire] Any advice, ideas ???
 

·
Registered
Joined
·
457 Posts
try using sea foam...i just seafoamed my svt and it seemed to have liven up the drivability...as for gas mileage... im still waiting to calculate my first tank...it seems to be worse, but idk maybe its a lot better and im just being over critical...

try fuel filter> might help?
 

·
Registered
Joined
·
457 Posts
oh and possibly and injector cleaner...(if you dont do sea foam)
 

·
Head Hurt
Joined
·
2,377 Posts
What about cleaning the MAF?
 

·
Max8
Joined
·
2,858 Posts
Discussion Starter #5
Oh, I forgot to mention a change of fuel filter less than 5 miles ago. I often use fuel system cleaners and injector cleaners. One of those little Lucas bottles every month. About cleaning the maf Brad, I did that as soon as I saw your post. I* cleaned with the maf cleaning thing they sell at autozone and it seems to do nothing. In fact, the maf itself wasn't that dirty at all, I try to keep my air filter as clean as possible always. Any more suggestions?
 

·
Head Hurt
Joined
·
2,377 Posts
Wish I knew more, but I always start with easy things and work my way up (to the mechanic most the time). How about a really easy one, disconnect the negative battery cable and leave if off for a 15 - 20 minutes to reset the ECU. Can only hope it would be that simple.
 
1 - 6 of 6 Posts
Top