Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I noticed a couple of days ago that my steering wheel has a little bit of play where previously it did not. It is making me a little nervous since I drive alot (500-600 miles a week). I recently had my steering rack replaced as well as the power steering pump. Now, by recently I mean that I had the rack replaced about 1.5 months ago, and the pump about 3 weeks ago. I only noticed the loose steering about 2 days ago. Does anyone think that the steering issue is due to the rack being installed improperly, or should I be looking at something else, and is there anything I can do to determine what needs to be fixed? I only ask cuz I work 70-80 hours a week and am rarely home during normal repair shop hours. Thanks in advance for any thoughts.
 

·
Registered
Joined
·
1,036 Posts
In all honesty you should take it back to the shop and let them check it out. It might be a loose tie rod end or maybe the tie rod toe adjuster didn't get tight. Just take it back to them and let them take a look at it. What I would do since you work so much is setup an appointment for them to look at it so that you are not waiting forever and let them know how tight your schedule is. At my shop we appreciate that cuz that gives us a chance to get it in right away to correct anything that might have gone wrong during installation.
 

·
Registered
Joined
·
48 Posts
Sorry to bring up a dead thread, but I am wondering how this turned out. Tonight I was driving down to my girlfriends place and I had to pull off the expressway onto the shoulder for a min, then when I pulled back on the expressway I noticed a play in my steering.
When I got to my girls place I turned the car off and took the key out. Usually the sterring wheel does not move at all, but now it still has about an inch of play.
I did not run over anything and I do not drive hard except for taking entrance/ exit ramps a little faster than I should. (What can I say? I ride a sport bike and love those curves.)
I drive a '02 ZTS as a daily driver and have about 76k miles on it. I do drive around Chicago and there are major potholes everywhere but do not believe this had anything to do with this problem.
I won't be able to look at it till I get home but any suggustions on what to look at or look for would be helpful.
Thanks.

- Will
 
1 - 3 of 3 Posts
Top