Focus Fanatics Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter #1
[?] On the rear left part of the motor (looking from front of car) there is a little 1"x1" black box that has what looks like a ground wire going right to the passenger side strut mount bolt. Not sure what it goes to but it has its own mounting bracket that bolts to the motor right by the header. What is it?!?!?! It's driving me nuts because the little black grounding wire popped out and ever since that my speedo and tack have been acting funny. Sometimes they will get stuck in a position (usually around 1500 RPM's) then it will go away after a few seconds. Think this might have something to do with it. Any insight would be greatly appreciated. [?|]
 

·
Registered
Joined
·
180 Posts
Discussion Starter #2


Here is an image of what I am talking about. I circled the black box and components in red. And whomevers picture I stole, I appologize. If you see it and would like me to remove it just let me know.
 

·
Sückn' n Blown
Joined
·
7,747 Posts
Can't see the picture, but based on the description, sounds like the radio frequency isolator, which filters out engine noise from getting to your radio.
 

·
Boost Addict
Joined
·
2,628 Posts
I don't see a image but I believe that needs to be attached. Maybe find a replacement in the junkyard focus and swap them out.
 

·
has a screw loose
Joined
·
9,927 Posts
Its right in the right top corner of my degas container, you can just barely see it .

 

·
Sückn' n Blown
Joined
·
7,747 Posts
Actually on my way to the dealer right now to get a new one for the Fusion. Thing is so weak, it can't hold up to a 1-ton hoist pulling an engine out if you forget to disconnect it.

[giddy]
 

·
Registered
Joined
·
180 Posts
Discussion Starter #10
Ok, thanks everyone. Just curious because I couldnt find any older posts on the matter. Thanks for the help and sorry the picture didnt show up. I can see it just fine when I open this post lol
 

·
Registered
Joined
·
446 Posts
i know exactly what that is its basically a ground/noice reducer for the radio and ant. mine was broke when i bought mine, you should not be having feedback threw your gauges that i know of.
 

·
Registered
Joined
·
5 Posts
So I ran into this thing and I had my motor out and of course this thing broke. I tried starting the engine and it was cranking but not firing. I took note of that black box thing with 2 black wires coming out of it and thought maybe it was a ground for the injectors or something since it goes through that harness. I put them together and I heard a sound that made me instantly regret what I just did and now the engine won't even crank now. Any idea if this goes through the ignition relay or something stupid like that?
 

·
Premium Member
Joined
·
44,595 Posts
The wire from the harness can NOT go straight to ground, that shorts it out and blows the engine fuse.

No different than connecting the ends of a lamp cord together then plugging it in - BOOM.

Harness to capacitor to ground is NOT essential for running, but it helps by eliminating electronic interference (radio, computers etc.). DO need power to the engine, NONE with a blown fuse.
 
1 - 14 of 14 Posts
Top