Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Just bought this 2002 ZX3 and am having electrical problems. Any help with would be appreciated.

Lights
Low beam lights rarely work. High beams always work. When I pull back on handle both low and high lights turn on as they should, but upon release the lights turn off if switching to low beam. Every once in a while they work. I tried switching the relays around, then put in some from a junkyard car, and nothing changes. Could the problem be in the multifunction switch?

Sunroof
Only the open switch works. Pressing the close side of the switch does nothing. But if you keep holding the open switch, the sunroof opens all the way then closes all the way. It doesn't stop at the end, just reverses directions.

Stereo
6006 model stereo. Volume doesn't work right. If I try to turn it up, sometimes it goes down, sometimes up, sometimes up then down. Same when I try to turn it down. I decided to get another 6006 from the junkyard, and it does the same thing. Is this a common problem with these radios, or is it in the wiring somehow?
 

·
C2H5OH
Joined
·
11,867 Posts
Lights,
The common problem area is the connector on the bulb itself. Many people replace the bulbs with ones that will draw higher amperage than the connectors are rated for and the connectors will deform/melt/short out. It's a common connector and a cheap part to replace. That's the first place I'd look.

Sunroof,
No clue. I don't have one so I can't say how it should operate. Does sound fishy though.

Stereo,
How fast are you turning the volume knob?
I know that if I'm trying to turn mine too fast or rather carelessly that it won't respond exactly as I wish. But if I take my time, turn slowly click by click it does exactly what I want.
It's an inherent flaw of the design of that style knob. It relies on a catch mechanism between the knob and the POT. If spun too quickly the two loose contact and nothing happens.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #3
Lights,
The common problem area is the connector on the bulb itself. Many people replace the bulbs with ones that will draw higher amperage than the connectors are rated for and the connectors will deform/melt/short out. It's a common connector and a cheap part to replace. That's the first place I'd look.

Sunroof,
No clue. I don't have one so I can't say how it should operate. Does sound fishy though.

Stereo,
How fast are you turning the volume knob?
I know that if I'm trying to turn mine too fast or rather carelessly that it won't respond exactly as I wish. But if I take my time, turn slowly click by click it does exactly what I want.
It's an inherent flaw of the design of that style knob. It relies on a catch mechanism between the knob and the POT. If spun too quickly the two loose contact and nothing happens.
I found another stereo at the junkyard that works fine, but still looking for help on the lights and sunroof.

Light comes on when I pull back, it just doesn't stay on, so the connector doesn't seem like the problem.
 
1 - 3 of 3 Posts
Top