Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
150 Posts
Discussion Starter #1
Hey all, wanted to vent some frustration and see if any other MK2's have had this problem.

Bought my '10 SES with 45k and the AC never really blew COLD, just cool. I knew the warranty was up so I never had it checked out. Well... the AC took a dump a couple months ago (75k) and we had to bite the bullet and take it to the stealer-ship.

So the evap core had a leak. Service mgr said there was already dye... I basically got screwed on this whole deal. Looks like the previous owner knew of the issue, but the dealer won't tell me if this was diagnosed by another Ford dealer. Big surprise.

I am just assuming, but this car supposedly was only worked on by a dealer in another city. Wouldn't the VIN show any previous dealer work in their system?

Charge was $1600 (dash removal, 10hrs labor, parts etc.) and that was after I talked them down $200. Anybody think this price is out of line?

They did do a great job. No evidence of them taking out the dash. Service mgr also said this is the second one he has repaired in any Focus ever. I'm thinking I just got a lemon part, but I'm having to fight the family off telling me to sell the car. Of course, it's been a great car besides that... and motor mounts lol!

Has anyone else had to do this repair?
 

·
Registered
Joined
·
150 Posts
Discussion Starter #2
Doing some searching... and it looks like maybe Ford uses dye in the AC from the factory. Geez I'm paranoid.... hehe.

Can someone confirm this?
 

·
Premium Member
Joined
·
44,595 Posts
Not a common problem fortunately.

Other than warranty repairs, Ford would have no idea what any Dealer might have done to the car.

A PO could certainly have added a can of refrigerant to the system, and most commonly avail. ones include oil/dye/sealant.
 
1 - 4 of 4 Posts
Top