Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Just put 2004 ZX3 seats in my 2003 ZX3 and the airbag readiness light won't turn off as well as the seat belt light and subsequent chime keep going off. Does anyone know how I can resolve this issue? I believe it is the wiring from the car to the seat since the seat's wiring is different. Please help, Thanks!!!
 

·
So mote be it
Joined
·
8,950 Posts
The easiest would be removing the wiring from the old seat and transfering it to the new seat. Otherwise you will have to do some splicing and figuring out, which some here might be able to give you a hand with but I am not familiar.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
Ok, thank you. The original seat had the mechanism is pretty securely fastened, do you know the best way to go about detaching it from the bottom of the seat.
 

·
Registered
Joined
·
1,218 Posts
If you didn't already, you need to swap your original (03) seat belt buckle onto the 04 seat.
That should take care of the seat belt light and chime.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I did that but the connecting piece from the seat belt buckle to the wire from the car must not be communicating properly.
 

·
Registered
Joined
·
1,691 Posts
all the wiring needs te be swapped. i did the same, i found it easier to put the bottom frame of the old seat onto the new seat. a control box of some kind for the air bag system that is rivited to it. you will most likey need/want to use the airbags from the old seats aswell. the only othere real option is changing out the whole computer system for the airbag system. the computers them self are different
 
1 - 6 of 6 Posts
Top