Focus Fanatics Forum banner

1 - 11 of 11 Posts

·
Haterz gonna Hate
Joined
·
2,156 Posts
Discussion Starter #1
well after the big trouble I had in NC of it breaking down... We brought it back home and replaced the following:
Replaced coil pack
Replaced plug wires
Replugged all vaccum leaks for the EGR system
Reset the ECU
Fuel filter changed
ground wires wire brushed and sprayed
checked all spark plugs
Cleaned the IAC a week before

Cylinder 2 on the coil pack had a scorched posted (blacked out) all the others were still gold

It ran like a charm yesterday... at high rpm the fuel wouldn't cut out at all no sputtering etc...

today on the way home i wanted to see if it was completely gone so i smashed the gas 1st into 2nd into 3rd gear...as soon as it hit 5k it didnt feel like a brick wall but i could tell power was cutting out, not like it should until 5,800rpm when it starts to float.... i held the gas down to see what it would do and it just acted like fuel was being sputtered into the engine... idk how else to put it... and NO CEL codes!!

I haven't really checked the MAF
I have a long tube header with flex pipe and borla exhaust
the EGR system is totally out of the car
the stock air box was removed and a filter put on the end of the intake tube
127K miles
do you think my engine is finally shittin on me?? :(
 

·
Hatch Nation #136
Joined
·
2,043 Posts
What does your maintanence schedule look like?

Have you replaced the fuel filter? IAC clean? What does your MAF look like? Mods? Is the mileage in your signature accurate?
 

·
Haterz gonna Hate
Joined
·
2,156 Posts
Discussion Starter #3
sorry i forgot to put some things in the OP ill do that now lol
 

·
Hatch Nation #136
Joined
·
2,043 Posts
I doubt your engine is dying out on you, especially at that low a mileage.

Any funny smells or sounds that went with it?
 

·
Haterz gonna Hate
Joined
·
2,156 Posts
Discussion Starter #5
nope, no funny smells or sounds
 

·
Hatch Nation #136
Joined
·
2,043 Posts
Okay, check the pigtail that goes into the coil for any issues.

Check the catalytic converter for clogs.

Check your fuel pressure to see if your pump is dying.

Double check your vaccum lines.

Check your timing belt.
 

·
Haterz gonna Hate
Joined
·
2,156 Posts
Discussion Starter #8
Okay, check the pigtail that goes into the coil for any issues.

Check the catalytic converter for clogs. I have long tube headers so no cat

Check your fuel pressure to see if your pump is dying. good possibility I might just go ahead and replace it.. but from what i hear they will just DIE and not gradually die

Double check your vaccum lines. definitely double checked I ran a small propane tank around the Intake manifold and the engine stayed at the same rpm

Check your timing belt.
was just recently changed at the Ford garage about 3 weeks ago
 

·
Hatch Nation #136
Joined
·
2,043 Posts
Didn't know there was a cat delete, that eliminates that.

Fuel pump might not be gone, but clogging. Like, the sock filter, or whatever.

Fuel injectors could be clogging.

Might have something gumming up your intake, since your EGR is deleted.
 

·
Haterz gonna Hate
Joined
·
2,156 Posts
Discussion Starter #10
Didn't know there was a cat delete, that eliminates that.

Fuel pump might not be gone, but clogging. Like, the sock filter, or whatever.

Fuel injectors could be clogging.

Might have something gumming up your intake, since your EGR is deleted.
I'm gonna do a fuel pressure test here in the week and see what it shows, and the intake should be fine because I did a clean delete and i capped everything off maybe i could spray some intake cleaner down the throttle body sometime


btw thanks for all your suggestions!!!
 
1 - 11 of 11 Posts
Top