Focus Fanatics Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Hi all,

I'm new to this page but wanted to say it was a blessing to stumble across.

So, getting down to business, I just recently purchased a used Focus. 2008 SES 4dr, Auto. I test drove it during the day so I wasn't aware of the lighting issues it had until the past couple of days. My gear indicator is not illuminated (neither the gears or the orange marker). Along with that I noticed that the controls on my steering wheel are not illuminated, niether are the headlamp control knob or the set of buttons at the lower part of the center dash which control the "info, reset" and all that for the main display / information center on the dash. Lastly, I just got a notification on the info center saying "tire pressure monitor failure" or something of that nature and now the little yellow "tire warning light" just stays on.

Are these common issues? I'm looking for repair solutions. Am I looking at bad bulbs or is it just fuses? I've called the local dealership and got absolutely ZERO useful information out of the service dept. They mentioned it could be a "switch" but really didn't know and said it could be anything. (yeah, cause that's not what I was already thinking. smh)

Any help would be much appreciated. Thanks guys!
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Appreciate the response. My fear is that it will be something in the dash and I'll have to rip the whole dang thing apart to fix it :/

I'll check the fuses when I get home from work and I guess just go from there. As far as the gear indicator / shifter light, I've heard peopel say it could be a bulb that needs to be changed out. Any truth to that?
 
1 - 3 of 3 Posts
Top