Focus Fanatics Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
140 Posts
Discussion Starter · #1 ·
my engine light keeps coming on and when i look up the trouble code it says intake manifold runner stuck upen. Anyone have an idea of what that means?
 

·
Registered
Joined
·
1,067 Posts
check your DSI clip to see if it broke (the little lever under the throttle body, it should have a cable attached to it)
 

·
Registered
Joined
·
140 Posts
Discussion Starter · #3 ·
it looks like it is still in place but i would have to reve up to 5k to see if it works, i thought that was it but i wanted to get some opinions of what it could be. I will try tommorow and see if it works (lil dark out)
 

·
Registered
Joined
·
1,067 Posts
that sucks, cause the other answer is more expensive... ( bad DSI motor)


does the car run like crap at low rpms, or feel under-powered at higher rpms?
 

·
FF Affiliate
Joined
·
31,181 Posts
Have some one watch it then turn on the key and start it you should see it move , with the car off it should be in the open position then key on and start it closes

Tom
 

·
Registered
Joined
·
33 Posts
....or, your intake is REALLY loud.
 

·
Registered
Joined
·
134 Posts
your runner is this little door that opens when the svt responds to aggressive driving. i dont know what happends if its stuck open though...
 

·
Banned
Joined
·
1,500 Posts
yea what tom said, i just had this problem. if the dsi clip is good its the box. mounted under the drivers side head light. the new box is 129 from mike and 18? from every other ford dealership. easy to replace tho. bust sux balls having to dish out that kinda cash. see if the cable is broken thats what was wrong with mine if not you can take it apart and fix it i heard.
 

·
Registered
Joined
·
727 Posts
This is an all too common thread. I wish Ford had designed the Dsi parts a little better.
If you wind up needing the dsi clip or lever, CFM makes a billet upgrade one that is great. If the box is bad, call Mike at Hilbish. Mike will get you a good price. Goodluck!
 

·
Registered
Joined
·
404 Posts
Exactly what blue focus said, call mike at hilbish. I had to go that route and it was not that bad. I dont remember the price but it was not that bad unless anything over 60$ is bad hehe. Good luck.
 

·
Registered
Joined
·
182 Posts
I've got an unused billet DSI clip laying around , if anyone wants it just PM me.
 

·
Registered
Joined
·
717 Posts
Could be the DSI clip or the IMRC. Like said already that would be the box under the drivers side headlight. I did the IMRC 6 moths ago and it was pretty easy I thought. I also just ordered the clip from CFM.
 

·
Registered
Joined
·
43 Posts
Could be the DSI clip or the IMRC. Like said already that would be the box under the drivers side headlight. I did the IMRC 6 moths ago and it was pretty easy I thought. I also just ordered the clip from CFM.
how much did you pay? i need one and my 3rd and 4th cylinder plugs are gummed up idk what it is but its throwing the p1518 code
 

·
Registered
Joined
·
114 Posts
mine is thowing that code too, a couple days ago I ran my car a bit fast, well it reached 6500 rpm, going to the movies, just for a short time, a mile or less. but when came back home I noticed that the car jerks when launch, but on high rpms pulled ok, so is a pain everytime I have to launch I need to rev up otherwise the car jerks like when kids are learning to drive[:I]

I thought the day after everything was going to be back to normal, but no!, then I scaned it with my SCT X3 and it displayed : intake manifold runner stuk open.

can it be released by hand or is something broken that needs to be changed???
 

·
Registered
Joined
·
114 Posts
mine is thowing that code too, a couple days ago I ran my car a bit fast, well it reached 6500 rpm, going to the movies, just for a short time, a mile or less. but when came back home I noticed that the car jerks when launch, but on high rpms pulled ok, so is a pain everytime I have to launch I need to rev up otherwise the car jerks like when kids are learning to drive[:I]

I thought the day after everything was going to be back to normal, but no!, then I scaned it with my SCT X3 and it displayed : intake manifold runner stuk open.

can it be released by hand or is something broken that needs to be changed???

Ok if someone else is as lost as I was here's the key:


http://www.focusfanatics.com/forum/showthread.php?t=222180

and most likely will need to fix this too


http://www.focusfanatics.com/forum/showthread.php?t=56157


fantastic information, it took me a few hours to fix it, needed to fix the DSI, was broken, I used that epoxy mixed with metalic particles and let it cure overnight, next morning I did put everything back in place and turned the engine on, so good, very smooth at low speed.

I want to thank this forum for this very useful information!!!
 

·
SVT Fanatic
Joined
·
2,615 Posts
LOL I like how you quoted your own post...

Anyway, yeah I haven't had any problems with the clip but the actuator needed replaced after 115,000 miles. I did that this past weekend. I'm not going through the work of cleaning the contact inside the actuator...
 
1 - 18 of 18 Posts
Top