Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Premium Member
Joined
·
6,442 Posts
Discussion Starter #1
My car had been running like a dog recently and finally it threw a code for me and of course it was the infamout P1518 for the IMRC stuck open. I just checked the clip and it is still intact so its not that.

next, when I start the car the actuator flips the valve up and releases when the car is turned back off, but nothing happened when I reved the engine up. Which direction is the valve supposed to be at idle? I have focus sports flash tune, so other than rpm what other parameters doed the IMRC look at? any help would be great. thanks

-Ben
 

·
Dragon Warrior
Joined
·
309 Posts
your motor has died I believe. that is exactly what happened to my 96 Mercury sable 24V Duratec when the IMRC motor died on it. new motor and my problem was cured.

prop the left side (drivers) of car up look in front of the fender liner and you will find the IMRC motor. make sure it is plugged in all the way.

the default for the motor is open so it will run like piss below 6000 rpm but perfect above it.

this is most likely the problem but I cannot guarantee anything.

if you are apt witha DVOM I may be able to get you some test steps.
 

·
Premium Member
Joined
·
6,442 Posts
Discussion Starter #3
the motor is opening/closing the valve on start up, so would it still move if its not functioning correctly?
 

·
Registered
Joined
·
78 Posts
If the actuator is working you should be able to tell while driving, the intake switches around 3500 RPM. I had that code and my unit was working fine. Turned out to be the switch inside the actuator, the contacts are pretty cheesy, you have to open the box up and clean them (a pencil eraser works good). bend the contacts back add some grease to the gears and good to go.

Hope this helps, its lots cheaper than buying a new one.
 

·
Premium Member
Joined
·
6,442 Posts
Discussion Starter #5
upon further review the actuator switches at ~~5100 or 5200 rpm, so we know that works.

any one with any idea why the car would have a rough cold idle and want to bog at low rpms?
 

·
Registered
Joined
·
2,731 Posts
THis is funny, I threw the same code tonight, P1518. I just came on here to ask some q's and lo and behold... let me know what works best for you and if you can give me any pointers Id greatly appreciate it, Im hardly a mechanic. ;-)
 

·
Dragon Warrior
Joined
·
309 Posts
you made it sound originally that it is only opening and then sticking.

but if it is switching at about 5100-5200 rpm then it is working fine.

there is a reason for that code.

is your car tuned?
 
1 - 7 of 7 Posts
Top