Focus Fanatics Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
102 Posts
Discussion Starter #1
This started yesterday, when I went to start my car in the morning the ideal stuck at 2k and I had to tap the gas pedal in order to get it back down. Not sure what it is, it doesn't seem to do it after I drive the car its just when I first start it.


Just changed the Oil and Air filter but wouldnt think that would have anything to do with it lol
 

·
Registered
Joined
·
400 Posts
Could be something as simple as a sticking throttle cable or throttle valve. go to your throttle body and check that just make sure everything is connected and looks right. Maybe get some throttle body cleaner from the parts store and give your throttle body the once over with it. it may be kinda "gunky" on the inside. Other than that the only thing i can think of is a vacuum leak but that would cause a constant high idle not just until you push the gas pedal. I'm sure more ppl will help you out, i hope i did a bit or gave you an idea.

Andrew
 

·
Registered
Joined
·
102 Posts
Discussion Starter #3
Vacum leak? Hmmm I am missing a screw in my airbox?
 

·
Registered
Joined
·
404 Posts
not trying to be mean but it is spelled "idle". Just thought it would help. Ow and when I ran my stock throttlebody it would stick whenever there was a change in weather ( cold or lots of moisture). Don't know if that helps, good luck
 

·
Registered
Joined
·
2,929 Posts
I always seem to find these threads. If this starts happening more and even when you drive it will 99% be your Throttle position sensor. Easy fix.
 

·
Registered
Joined
·
400 Posts
Screw in the air box not a problem. Could be TPS for sure, but try cleanin it once see it its just dirty inside. thats def. a possiblilty.

Andrew
 

·
Registered
Joined
·
400 Posts
OH SNAP...JUST THOUGHT OF THIS IAC or idle air contro vavle DEFINATELY a big possibliltyi think. That would take some slight testing though. but that is def a good idea to check...

Andrew
 

·
Registered
Joined
·
3,487 Posts
Sounds like a sticking throttle plate to me also. The inside of the plate gets covered w/gunk, and is very difficult to clean well with the use of a spray only. The best method to clean the thing.....use a tooth-brush and carb cleaner. Be certain to clean the areas of the body itself where the plate seats.

A clean plate will make a nice, sharp snap sound when it closes properly.....a gunked-up plate makes a softer sound. Good luck...
 

·
Premium Member
Joined
·
21,235 Posts
Clean the TB first because it costs less, and check for vacuum leaks. The easiest way to check is to spray (on a cold engine) starting fluid around the engine compartment while the engine is running. If the engine speed increases, then you should look in that area for a vacuum leak.

The IAC is a possible cause, but generally when these go bad there is no start up idle increase, nor AC increase, or anything else to do with idle. It doesn't generally cause the idle to go up. If you think it's causing the problem, try tapping it with a wrench while the idle is sticking. If it goes down, then it is causing your problem- and you should go buy a lottery ticket.
 

·
Premium Member
Joined
·
3,110 Posts
I had a eagle talon that did the exact same thing except it stuck at 3k until i tapped the gas it was the TPS & a dirty throttle body. Not positive on which fixed it i cleaned the tb and switched out the TPS at the same time.
 

·
Registered
Joined
·
50 Posts
The IAC "Idle Air Control" is controlled by the computer. It parks in a certain position when the car is shut off. If the conditions change significantly it will cause the car to idle high on initial startup. After a few seconds the car should adjust the idle down to normal. When you first start up your car in the morning don't give it any pedal for startup. This makes the IAC find its correct "park position" Just let the computer do all the work. If the computer doesn't correct it then you have a problem. IAC's very rarely fail. If you have an OBD2 scanner you can check that the IAC is working while you are driving around.[burnout]
 

·
Registered
Joined
·
102 Posts
Discussion Starter #14
lol Moved my post from SVT Prformance chat to here? How is my ideal sticking not a preformance matter? ;)
 

·
The Librarian
Joined
·
13,116 Posts
I'll tell you why.
The "Performance" area is to discuss:
The place to chat about any SVT or European ST engine performance, tuning and exhaust related upgrades.
Emphasis on upgrades.

The "Technical Chat" is for:
This section is for technical discussions relating to general maintenance, electrical issues, engine trouble, and recalls.
See?
Engine trouble which is exactly what you're experiencing.
Make sense? [;)]
 

·
Registered
Joined
·
102 Posts
Discussion Starter #16
"engine performance" I am also experiencing decreased preformance from my engine :)

While I can understand the move I feel justified in my decision to post in the SVT Preformance section lol




PS You know I really don't care about the move right ;)
 

·
The Librarian
Joined
·
13,116 Posts
PS You know I really don't care about the move right ;)
All righty. [;)]

Try and think of it this way:
Performance section is for performance enhancements (upgrades).
Technical section is for performance problems (trouble).
 
1 - 17 of 17 Posts
Top