Focus Fanatics Forum banner

1 - 18 of 18 Posts

·
Registered
Joined
·
1,484 Posts
this isn't coming from past experiance or anthing but on my old truck we got a "performance" clutch for towing purposes it is was so much better than stock...we didn't even have to replace the stock clutch but did it anyways just to have a better clutch....

...my suggestion, go with something better than stock... you would like the stage 2
 

·
Registered
Joined
·
1,136 Posts
On that same page site. I was just looking for a stage 3 and came across a 1 and the 2 you linked to.
 

·
Registered
Joined
·
764 Posts
Discussion Starter · #9 ·
I got the stage 1 and its at the shop right now to get installed. I'm hoping I get it back in like 2 days so I'll let you know how it feels.
 

·
Registered
Joined
·
1,136 Posts
Stage 2
 

·
Registered
Joined
·
764 Posts
Discussion Starter · #12 ·
So I got my car back today, and let me say, this clutch is COMPLETELY different from the stock one, it's so much smoother. I would recommend it to anyone. It's so different that the first time pulling away i almost stalled it, but caught myself.

Only problem is that when I was driving and went to put it in 5th, it was like there was no fifth gear and just revved as it was in neutral. I immediately turned around and brought it back, but i was wondering what would cause this. I talked to the mechanic and he said he doesn't know why its doing this since he just took out the tranny and put the clutch in. Any ideas on this situation?
 

·
Registered
Joined
·
764 Posts
Discussion Starter · #15 ·
I have a question. My car has been making a whine sound before i got my clutch installed, and i thought the noise was from my clutch, but now that i have a new one the noise is still present. What would this be? Will it stop after break in?
 

·
Registered
Joined
·
1,146 Posts
I have a question. My car has been making a whine sound before i got my clutch installed, and i thought the noise was from my clutch, but now that i have a new one the noise is still present. What would this be? Will it stop after break in?
it could be the fuel filter or the gas lines, you might want to buy some fuel in
jecter cleaner[idea] its just an idea, or gas treatment to flush those lines clean

i had a problem like that with my first focus and i changed the fuel filter
air filter, and put gas treatment in my tank and it fixed the problem
 
1 - 18 of 18 Posts
Top