Focus Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
94 Posts
Discussion Starter · #1 ·
Some of you might remember me mentioning this before... but I'm interested to know if others have experienced the same issue. I got my car back today, as it wasn't fixed until just this past Saturday.

Well I had my 2012 focus hatch for exactly 2 days before my check engine light came on and I had to bring it to my service department. I promptly had to leave it there for 2 full weeks. (luckily one of the weeks I enjoyed a family reunion on the other side of the the USA in California so I was able to relieve stress far far away.)
The dealer didn't even take the car out of the dealer's name yet!

Anyway, they were extremely nice, and everything is covered by my warranty.

The customer copy of the parts & labor sheet says "replaced processor assembly, replace hego sensor, replace tube assembly". What's very concerning about this is they had to replace the entire module. They told me the manufactory had to change the way they put together the PCM in order to correct the glitch. And it seems like there is more than one 2012 focus getting this new PCM computer because I had to wait 2 weeks to receive the part. (says part #CM5Z-12A650-KJ) So I must have been in line in order to receive my part. But I doubt they'll have a recall.

Anyone else having to get their PCM replaced?

The car runs fine now, no errors yet. I'm concerned something might come up later, but it is saved with the vin number, so there is a history.
 

·
Registered
Joined
·
588 Posts
Happy to hear you're back on the road. :)

I haven't had to get anything at all replaced. Just passed 6,000 miles and have not had a single problem.
 
1 - 3 of 3 Posts
Top