Focus Fanatics Forum banner

1 - 12 of 12 Posts

·
Breathing. Alive?
Joined
·
3,108 Posts
Discussion Starter #1
So I replaced my super dirty air filter. I turned the car on and after a minute the check engine light came on. I look in the hood and the MAF sensor was a bit loose so I tightened it but now I'm stuck with the CEL and I feel like there's some extra shaking and noise coming from the car.


Help me!!!

The car seems to start fine and idles no better than usual. I drove it down the street and back and it felt fine besides a little shaking as I decelerated on 1st which is normal but my mind wants to believe it was worse than usual.
 

·
Vince your Moderator
Joined
·
5,074 Posts
Have you cleaned said MAF with throttle body cleaner? Is the pigtail plugged back into Said MAF?
 

·
Breathing. Alive?
Joined
·
3,108 Posts
Discussion Starter #3
Have you cleaned said MAF with throttle body cleaner? Is the pigtail plugged back into Said MAF?

Don't have any. and what is this pigtail you speak of?
 

·
Breathing. Alive?
Joined
·
3,108 Posts
Discussion Starter #4
So I went deep into the internet for answers and a lot of people say that by unplugging the MAF sensor, I set off a code. I'm gonna drive it to class tomorrow and it should turn off but if it doesn't, I'll take it to autozone or something to check the codes.
 

·
Vince your Moderator
Joined
·
5,074 Posts
Good call.
 

·
Registered
Joined
·
495 Posts
After the MAF has been plugged in, unhook the (-) negative battery terminal and reset your ECU. Then start up the car and see if the CEL comes back on.

If the CEL comes back on with poor idle or operating condition I would be a bit hesitant to be driving it around too much. Check all of your intake connections after the MAF and make sure you didn't leave anything unhooked, loose or possibly cracked something. Any of that would cause an air leak. aka vacuum leak.
 

·
Breathing. Alive?
Joined
·
3,108 Posts
Discussion Starter #8
Got the CEL checked and it was the MAF. The Idle is still not that amazing but there are many other causes for that. The CEL has not come back on yet and the car actually moves now. The old filter was extremely filthy. *sighs in relief*
 

·
Registered
Joined
·
495 Posts
This is why I usually recommend doing an ECU reset after any sort of filter change or intake/MAF sensor cleaning or any engine maintenance or modification. The ECU will then set up from a clean slate for the changes made.
 

·
I Like Red
Joined
·
3,245 Posts
After the MAF has been plugged in, unhook the (-) negative battery terminal and reset your ECU. Then start up the car and see if the CEL comes back on.

If the CEL comes back on with poor idle or operating condition I would be a bit hesitant to be driving it around too much. Check all of your intake connections after the MAF and make sure you didn't leave anything unhooked, loose or possibly cracked something. Any of that would cause an air leak. aka vacuum leak.
^ This, if you get a CEL because you forgot to plug something back in then started your car, just undo the (-) on the battery and let it sit for 20 min or so to drain all the power out then reconnect and start car. Like I told you before, if you ever need a hand or help with your car just PM me or text me. I am always glad to help out, chances are I have been there and done that. I also have a code reader so I can check your codes if you ever have any. [wrenchin]
 

·
Breathing. Alive?
Joined
·
3,108 Posts
Discussion Starter #11
^ This, if you get a CEL because you forgot to plug something back in then started your car, just undo the (-) on the battery and let it sit for 20 min or so to drain all the power out then reconnect and start car. Like I told you before, if you ever need a hand or help with your car just PM me or text me. I am always glad to help out, chances are I have been there and done that. I also have a code reader so I can check your codes if you ever have any. [wrenchin]
Damn it! I totally forgot you live like 15 mins away. Well, I know I'll screw something up again soon so I'll hit you up. Lol
 

·
I Like Red
Joined
·
3,245 Posts
^ Yea dude, don't be shy. You got my #, use it. lol. I can help you clean your MAF, definitely a good idea to clean it regularly. It only costs like $5-$6 for a can of cleaner. I clean mine every time I clean my air filter...
 
1 - 12 of 12 Posts
Top