Focus Fanatics Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
508 Posts
Discussion Starter #1
I am sorry my friends, my team for being messed up

I am sorry that i was immature

I didnt want to but i did and for that i am sorry

I learned my lesson after being kicked off for 7 days.

I hope each and everyone of yall can accept my apology.

I am sorry team for what I said.



i hope you all can help me out....

my 09 coupe is making a popping noise coming from the front of the car.. either when driving- slow- straight in the parking lot or while i am turning the wheel and sitting stationary..
i dont hear this noise while driving faster than in a parking lot ..but I do hear this popping noise when accelerating thru right turns..
i believe this noise is coming from both the drivers side and passenger, but still not sure I almost want to let it brake on purpose so i dont have to replace something i dont need.. <due to finances..

so this problem I have is in the front and its not the best noise- sounds terrible- sounds like it will break any minute..

I have my car LOw with H&R coilovers <(wow this is bomb suspension)
stock snowflake wheels bcuz my 17' Tenzo Racing wheels are for sale

Thank you my Team and thank you for everything youve done in the past!
Sincerely,
Derek Gordon

2009 coupe Vista blue SE
3D carbon 4 piece body kit
16" snowflakes with H&R coilovers
FSwerks CAI and stock exhaust no resonator.
 

·
Focal Distortion
Joined
·
2,332 Posts
Most likely its your swaybar end links, they wear out stupid fast when lowered.
 

·
Registered
Joined
·
1,913 Posts
sway bar end links, there was a tsb put out about them.
 

·
Registered
Joined
·
591 Posts
It's your endlinks. Especially if you never changed them once you put the coil-overs on. Mine do it randomly since I'm on springs, and still on stock endlinks.
 

·
Boosted HB.
Joined
·
1,698 Posts
I agree.. Sounds like CV joints going out.
 

·
Registered
Joined
·
508 Posts
Discussion Starter #9
I took it to FSwerks yesterday and we looked at it briefly....
it looks to be the passenger Coilover its loose and needs to be tighten...
you can see it moving..

by chance has anyone experienced this...
and i will check the end links of course and i thank each and everyone of you for your responses!!

thank you <3
 
1 - 9 of 9 Posts
Top