Focus Fanatics Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Moderators pardon if i am reposting it here, i am new and in need of any assistance

How to properly reset ECU/CEL/Check engine light w/o scanner?

How to properly reset ECU/CEL/Check engine light w/o scanner?
Hi,i am new.. any help would be highly appreciated.. I have a 2010(facelifted) MK2.5 Focus with DuratecHE 1.8gasoline engine,stock form-no amps etc.I'm from the Philippines(S.E. Asia).. bought it used last 7months ago..Love the car.runs well until 3 days ago when all of a sudden the CEL/check engine light comes on and still on(not blinking) while driving..I took it home readily(20min drive), the car still runs well(apart from CEL /check engine light) and still idles well (never drove it since check engine light)..Initially I'm getting (via car display/instrument cluster trick w/out OBD2 scanner) a DTC A895(trip computer module switch circuit failure)..I opened the engine hood and noticed a broken negative battery led connector and had it replaced..I have tried every trick found googling from this site as well as others to properly do a "battery reset"/"GM-global reset", but still can't remove the check engine light. After trying different battery reset styles I have now 5 DTC codes: A895,.9681(PATS tranceiver signal is not received),.9318(batt volt low),. D900(non specific can communications interruption),. A103(antennae not plugged in or faulty connection)..I already had the battery checked,(cluster reading a 12.2v in 'on" ,.13.5-13.7 in idle)..I am currently located in a place about 200km from the nearest Ford dealership or any shop with an OBD2 scanner, and i dont want to drive that far at the risk of damaging the car, so I am asking for your insights on "HOW to properly 'BATTERY RESET'(without an OBD2 scanner) to 'REMOVE' the CEL/Check engine light??"

I have already tried the following Batter Reset styles:
1.remove the positive connector 30mins
2.remove the negative connector 30mins
3.remove both connectors 10hours
4.connect both connectors with each other(both detached from battery posts)
5.detached negative connector 5min,then put headlight on,blew the horn,applied brake,key in 'ON' position,. a combination of previous with positive connector detached,. a combination of before with both connectors detached.
6. combinations of 1-5
7. even the lighter trick :)

I am unable to use the car for 3 days already and my current location(200kms away) prohibits a visit to a Ford dealership or access to an OBD2 scanner,. so any suggestion on 'how to remove the CEL / Check engine light??" would really be appreciated..thank you.
 

·
Registered
Joined
·
15,429 Posts
You don't have enough electricity..............12.2 is low enough to give trouble and you need at least 14.0 volts charging or the alt is defective, at least on the American alternators we use here. 13.5-13.7 is a bad alt here. Need a minimum of 12.3 volts not running and preferably higher. A good new battery can be up to 12.8 volts and the norm used is 12.5-12.6. The electronics give trouble with low voltages and phantom codes then show up.

As well, the light will not go away until any issues putting it on are fixed.
 
1 - 2 of 2 Posts
Top