Focus Fanatics Forum banner

1 - 8 of 8 Posts

·
TURBO ZX3
Joined
·
8,746 Posts
Discussion Starter #1
its been bout 4 thousand miles on my set and I noticed a misfire today around 4.5k rpm
 

·
Meh.
Joined
·
10,609 Posts
I've only replaced my Spark plugs once, both at around 100,000. Both cars were used when I bought them so they may have been replaced before. I don't intend on replacing them again for another 50,000 or so miles. Checking their gap fairly regularly is a good idea, though.

As for your misfire, it could be simply a bad plug, your plug wires, a coil going bad. I'll freely admit that I don't know much about turbos but maybe that may causing some stress for your spark plugs too.
 

·
FF Affiliate
Joined
·
31,095 Posts
I am sure he ment , How often do the boosted guys change your plugs , I change then 2-3 times a year or every time I go to the track and keep a set in the car at all times

Tom
 

·
TURBO ZX3
Joined
·
8,746 Posts
Discussion Starter #6
That is what I meant. Hence why it's in the forced induction area.
 

·
I need BOOOOST!!!!!!
Joined
·
6,125 Posts
before FI i changed them every third oil change. havent done enough miles since the changeover to know with turbo. pull the plugs, inspect them thoroughly, put in fresh ones. if the misfire happens again, coil pack. hell id check the coil pack out anyway. i had 3 go bad in as many months once. first was just old, next 2 were chinese no name crap brands that lasted a few weeks, finally went and bought a legit motorcraft and havent had issues since.
 

·
TURBO ZX3
Joined
·
8,746 Posts
Discussion Starter #8
legit brand new motorcraft is in and I did new pig tail mod for it too. I will jist install new plugs at a smaller gap
 
1 - 8 of 8 Posts
Top