Focus Fanatics Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
800 Posts
Discussion Starter #1 (Edited)
this just started when im coming down off of high rpms and im still rolling to a stop my rpms wont drop past 1200 and then when i stop they linger in the 1000 range then they drop down to about 600 then it tries to die then the idle is just up and down from 1000 to 600 like im tapping the gas then it will almost die sometimes it will die, it says i have a fuel injector failure but i dont know which one it is, my mods are: intake (sr) tb spacer for my spray that i never got and exhaust, if i put the svt injectors in my zx3 will it help it any?

i guess what im asking is opinions on what this might be, and if it has ever happened to anyone else let me know please
thanks
knox
 

·
Shot me 3 deer!!!
Joined
·
9,247 Posts
sounds like a little bit of blow by in the tb
 

·
Focus autox'r
Joined
·
2,507 Posts
Yeah sounds like its sucking in un-metered air, or dirty maf sensor=clean with maf cleaner.
Maybe try some fuel injector cleaner.
 

·
Registered
Joined
·
442 Posts
this problem sounds familar to me...i think when my pcv hose collapsed at the elbow it caused it. check down on the back of the IM for the hose coming off of it.
 

·
Registered
Joined
·
25,621 Posts
I would check both sides of the TB spacer ( spray around them with some wd40 or something) and see if the idle changes, if it does, you have found your air leak.
 

·
Registered
Joined
·
897 Posts
yea deff a leak somewhere, check all vacuum lines..to egr solenoid, evap canister, fuel rail and pcv hose. Theres a few more but those are what i got off the top of my head. Also check for the obvious like loose hose clamps, sensors etc. Injectors are cheap if you can get em at the salvage yard.
 

·
Shot me 3 deer!!!
Joined
·
9,247 Posts
Or he can just buy my injectos!!! [neener]
 

·
Registered
Joined
·
800 Posts
Discussion Starter #9
lol if u got svt injectors i might take you up on that offer but my tb spacer is sealed up tight as a drum ill check all my hoses tomorrow and im bout to delete my egr and get my buddies at dynospeed in memphis to get me a tuner, thanks for the suggestions keep them coming if ya got any

thanks
knox
 

·
Registered
Joined
·
800 Posts
Discussion Starter #13
where might this valve be located a pic would be very helpful thanks guys for all ur help
 

·
Registered
Joined
·
800 Posts
Discussion Starter #14
well i disabled my egr and it runs great, it dosent try to die but the idle is still way high then it drops but holds steady so hopefully these svt injectors will solve that
 

·
FF's Night Security
Joined
·
28,766 Posts
I still say IAC its between the intake manifold and engine block. It hard to change with the intake manifold on the car but it can be done. Though i do recommend just taking the intake manifold off it way easy to do than contort you hand in weird positions to try and take it off that way. It controls the idle and will cause the exact symptoms you discribe "hanging RPM's, Horrible idle". Its really no that hard to replace and give you a good look at whats under that intake tube and intake manifold so you can become "closer" to your car lol.
 

·
FF's Night Security
Joined
·
28,766 Posts

·
Registered
Joined
·
48 Posts
Try disconnecting your battery, then reconnecting it, my ECU forgot how to idle properly i think :S, i just did the above and my ecu relearned itself and everything was okay:)
 

·
Registered
Joined
·
68 Posts
It could be the IAC valve, or vacuum lines, but when i installed my intake and full length header I ran into the same problem. All my mustang buddies thought i had cams. Start with free simple fix of disconnecting the battery and work your way up from there. Remember to leave it disconnected for a min so it completely resets.
 
1 - 19 of 19 Posts
Top