Focus Fanatics Forum banner

21 - 22 of 22 Posts

·
Registered
Joined
·
104 Posts
Try and find a pcm from a junk yard maybe. Definitely have to make sure same model and trim level. There is a guy on Facebook that runs 5acreFocus, he sells on eBay a lot. I'd try getting in touch with him along with giving your Vin number, he'd be the best bet in my book to get you the correct part. Just ask him to list it on eBay and carry your business in through that forum so that you have assurances on what your buying through their sellers platform. Not sure if there'd be a refund, but at least your better protected.
Second thought about the grounding issue as a possibility. You can buy several get of 8 gauge wire, speaker wire is a good choice, and run a couple of extra grounds from your battery to engine and also to the body of the car. Just YouTube it. That will teach you how to properly do it. That will knock out that as a possibility.
Thirdly, if it is a short in the wiring somewhere than that's a whole lot of chasing, but again a possibility. If a wire is frayed somewhere between any of the engines sensors, you'll have to test reach one for voltage, or open.
Best of luck brutha
Tomorrow I tackle all my suspension work, shocks, struts and springs! Oh Lord, sounds like the Wizard of Oz. ?
 

·
Registered
Joined
·
17 Posts
Discussion Starter #22 (Edited)
the shop I took it to gave up and said that they couldn't find the cause of the problem and I should take it to Ford. I dove into some wiring diagrams and realized that PCM diode could definitely cause the intermittent stalling, especially since the guy at the shop told me that the engine was just "losing communication" with the PCM in the middle of driving. Went to the junkyard and got a handful of PCM diodes. Swapped out the old one with the "new" one and now my acceleration troubles as far as it dying when trying to accelerate seem gone. Immediately after changing that and starting the car up though it was idling really rough and seeming to want to stall when parked or at an idle, revving the engine slightly seems to keep it alive. I finally got a check engine light after 2 weeks replacing parts. P2195 sensor 2 stuck lean. Just waiting on the parts store to get it in from their store up north, gonna swap out the o2 sensor and see what that does. I swear every sensor on this vehicle is the OE from 03 lol. My fuel pump definitely was!
 

Attachments

21 - 22 of 22 Posts
Top