Focus Fanatics Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 2001 zx3 dohc. It will start up but idle very rough and then kill in less then a min. i know my fuel pump is working because where getting fuel up to the rail and i tapped on it a little bit and it seemed to help so is it the pcm or somehing in the rail. it just did this radomly and never had any sighs of this.
 

·
Registered
Joined
·
6,175 Posts
could be the Throttle Postion Sensor (TPS)
maybe a vaccum leak...

someone will give you better direction but atleast thats a place to start
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
yea i put in a new crank sensor but that didnt do any thing for me ill check the tps too thanks for the sugestion
 

·
Premium Member
Joined
·
44,595 Posts
Lots of possibilities, more info needed....

Fuel filter replaced ?

get gas recently? (water in gas happens....)

I'd START with a "plug check" to see what's going on...

You didn't happen to wash it recently did you?

How's the weather been in Minn. recently?

Just a FEW questions so we have an idea which possibilities are most likely to help you out....
 

·
Registered
Joined
·
2,193 Posts
yea i put in a new crank sensor but that didnt do any thing for me ill check the tps too thanks for the sugestion
Dont go wasting $$$ throwing parts at it. You will get better help here actually diagnosing the problem. Usually something simple and cheap. Like above ^^^
need more info, as to what led to this situation...
 

·
Registered
Joined
·
12 Posts
Not sure if I got this video attached properly, if not, I found it on YouTube under the title, "2000 ford focus 2.0 DOHC - Engine Randomly dies - FIX?" the author to this video is Viper19861986. I'm having a similar problem, recently after running around town with short multiple stops the car would die as soon as I started it up. I found myself playing with gas pedal to give her fuel and the clutch at the same. On stop of that, my clutch pedal was not making contact with the Ignition safety switch. So the car dies at intersection, I'm trying to reach the switch to push it in and trying to start it at the same time...LOL! The ZX3 has no problems if it sits awhile or overnight just on short multiple stops...damn honey due list, ZX3 hates it as much as I do some days! I thought this was interesting maybe someone can tell us if this is a good idea or not?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #7
i checked the plugs and 2 where cracked i replaced them and it ran fine then it started doing the same thing after a little bit and the check engine light is on and its reading a distributer code and i ran a chemical through the gas to get ride of the water if any and im stuck again
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
the car had been sitting for a while and i ran a half take through will no problums then i went throung 1/4 and then it happed it had no sighs of any beside if i was costing in neutral it would kill some times but not all the time and it has been very dry with not alot of rain and its starting to get colder it was raining for the first time when it happend
 

·
Captain Retard
Joined
·
2,583 Posts
Check your coil for cracks. Moisture might be getting in there and causing a misfire.
 

·
Aurelius Pardus
Joined
·
26,535 Posts
check the coil, check the pcv hose to see if it's collapsing in on itself during idle. Sounds like it COULD be that. something to check.
 

·
Captain Retard
Joined
·
2,583 Posts
Okay, so .......you're getting fuel, spark and everything else. Fuel filter? Wiring going to the coil? Sticking injectors? Did you check your air intake for any kind of rat's nest? Running out of ideas. Maybe a squirrel is living under your hood and chewed some wires up...................lol.
 
1 - 12 of 12 Posts
Top