Focus Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I understand this code is something to do with lack of speed data being picked up?
Is this causing my speedo to drop to zero?
And my car to judder?

How do I solve this problem?

Thanks in advance.
 

·
Premium Member
Joined
·
44,595 Posts
Moved to General Tech Chat where you can find info. & get tech. suggestions.

You'll need the rest of the digits for that code (4 numbers), then you can find a good description in the DTC code section here:http://www.focusfanatics.com/forum/showthread.php?t=174739

That's one of the 'stickies" at the top of this section.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
I had a look in the dtc code description and says

D041 SCP (J1850) Invalid or Missing Data for Vehicle Speed

How do I solve this problem?
 

·
Premium Member
Joined
·
44,595 Posts
Looking a little deeper, I find that as an instrument cluster code as opposed to a DTC from the OBD port - so the number is valid assuming you got it from the test mode of the cluster.

It could be a cluster fault, a communication fault to the cluster, or anywhere back to the speed sensor itself (communicates from sensor to PCM to cluster).

One way to narrow it down would be to test with a scanner at the OBD port, a good reading there would put the problem at the cluster or in communication to it.

Do you have an automatic?

Speed sensor intermittent would cause shifting/operation problems with that (judder possible) as the output speed is an essential sensor for proper transmission operation.
 
1 - 4 of 4 Posts
Top