Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
273 Posts
Discussion Starter #1
i have been having a problem with suspension noise ever sence i replaced my suspenion with the svt kit.
sound comes from the front knocks when slow turns and makes clunck also when going over bumps??

ive had the suspension on kon for over a month and it gets worse and worse???
please help[???:)]
i got my car on jack stands rite kno
thanks
chad h
[???:)] [???:)] [???:)]
im stumped
and ive searched around the site and got no answer
 

·
Registered
Joined
·
2,228 Posts
Are you sure that you got the pillowmount bolt torqued to specs? Your strut could be boucing around in there. That's where I would look first.
 

·
Registered
Joined
·
273 Posts
Discussion Starter #3
hey

hey thanks for your response but every thing is all good up top with the strut mounts
and every thing is tight up there

but i have heard stuff about the front sway bar not being centerd that could cauz this problem
does any one kno about this

please helpme its gettin worse and worse[???:)]
 

·
Registered
Joined
·
273 Posts
Discussion Starter #4
i got the problem

my sway bar had become lose in some spots and that was most of the noise i just retightened envery thing and all the sound went away exspect for a little in the upper right, and i have heard that this could be a bad strut mount... so my car is much better kno i just gotta get i new strut mount i gues
 

·
Registered
Joined
·
4,805 Posts
to determine if the strut is making the noise...
I opened the hood of my car, then shook the front end violently by pushing it downward with my arms.

Then I noticed that the top pillow-mount, or strut nut, was loose.
 
1 - 6 of 6 Posts
Top