Focus Fanatics Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
Sorry guys and girls, this is going to be long, but i really need some input on what the problem could be so try to make it through.

ok, so i'm driving to work this morning on I-75 and out of no where my car kicks into safe mode and my check engine light starts flashing. I slowly make my way to the off ramp. Pull over, turn it off, start it up again and it seems fine. I drive it all day at work, then, on my way home i notice that if i'm cruising along and try to accelerate in 4th or 5th gear, it kind of chugs and doesn't really want to go any where And then, i'm stuck in traffic, in neutral, and my car starts to shake really bad and stalls. I start it up again and it keeps shaking real bad and the only thing i can do to keep it from stalling is to obnoxiously rev it.

Here are my mods:
FC 2 piece UDP
FC Offroad downpipe
Focussport exhaust
Ported Throttle body

Any suggestions on what the problem could be would be greawtly appreciated. Could it be one of these mods? I haven't done anything to the car in about a month, the downpipe was the last thing. It seems that if this was the problem it would have happened before now.

Thanks
Jess
 

·
Registered
Joined
·
4,825 Posts
It might be something else, but it sounds to me like your fuel pump is failing. Same exact thing happen to my truck a while back. First it starts to idle really rough, then lost of power and eventually it quits starting.

If it backfires, then I'd probably check the plug and wires first.
 

·
FF #1 Most Wanted
Joined
·
6,890 Posts
Don't overlook the obvious. Look under the hood for anything that may be loose like
spark plug wires, coil, etc..
Good luck.
 

·
Registered
Joined
·
13 Posts
[8)] First what year is your Focus?? The problem with the fuel pump's was the Focus 1999 to 2000. In the 2002 to 2003 the problem was solve, as same was with the corrosion of the battery and the problem with the brakes.

Check the campaings in internet by Yahoo.


Cheers!![:D]
 

·
Registered
Joined
·
97 Posts
Discussion Starter #5
My focus is a 2001. It was doing the chugging thing for a while and i took it to ford and they said they replaced the fuel pump, but I don't know, it still didn't run right. My boyfriend and I just checked the spark plugs and wires and they didn't look too bad. The wires were fine, one plug was a little oiley but nothing horrible. How do i go about checking the coil? Another kid on the focus connection said thats what he thinks it is. I really want to get this fixed without losing my car to the mechanics.
 

·
Registered
Joined
·
13 Posts
[rolleyes] Check the fuelpressure of the fuel pump. If is the coil, first you suppost to have a "Check Engine" and second i think your car dont start to soon(remember this engines don't use ignitions, we use ecu and controls modules). I think is the fuelpump.....


[8)]
 

·
Registered
Joined
·
97 Posts
Discussion Starter #7
How do i check the fuel pressure on the fuel pump? So that would be intermittant problem then? because it doesn't run bad all the time, only half the time [:(] My boyfriend said that if it was the coil, it should be doing it constantly and like i said, its not. Anyways, thanks for helping. I'd appreciate any other ideas.
 

·
Registered
Joined
·
205 Posts
FocusJES said:
My focus is a 2001. It was doing the chugging thing for a while and i took it to ford and they said they replaced the fuel pump, but I don't know, it still didn't run right. My boyfriend and I just checked the spark plugs and wires and they didn't look too bad. The wires were fine, one plug was a little oiley but nothing horrible.

Hmmmm... I was going to suggest the fuel pump myself. I had a similar problem with my Daytona years ago. I'd be plugging along fine, come to a stop and then when I'd accelerate, my car would hitch and chug-chug-chug. I friend's BF look at it... Come to think of it, all he had me do was get some plugs and a cap at Pep Boys and then the car worked like a dream.

Sorry that I couldn't be of more help.
 

·
Registered
Joined
·
3,861 Posts
the reason our fuel pumps get clogged sometimes is because of the lining in the gas tank. did they replace your gas tank also? id get the CEL checked and take it back in.... good to hear from u again btw jes :)
 

·
Registered
Joined
·
97 Posts
Discussion Starter #10
Thanks christopher. You stopped emailing me [:(] I moved home from college and didn't have the internet for a while. But i'm back and as addicted to FF as ever.

They didn't replace my tank, they just said the fuel pump and fuel filter. But, i don't know, I've had my car into the dealer like 4 times in the past 1 1/2 years and usually for the same thing. Nothing ever seems to get fixed there. A guy on another forum said autozone will scan my car for free and tell me what the CEL brings up but i'm sure its just going to say it was missfiring which won't really help me.

So chameli you're saying that it wasn't your fuel pump? Because that is exactly what mine does. Just plugs and a distributor cap?

I wish i knew where to start. It seems to be either my fuel filter, coil, or plugs. I just want my car to run so i can get to work, to make money, to buy things for my car that will probably mess it up again. [:D]
 

·
Registered
Joined
·
205 Posts
FocusJES said:
[B/] So chameli you're saying that it wasn't your fuel pump? Because that is exactly what mine does. Just plugs and distributor cap? [/B]
Yeah... I think so! I'm sorry! That was a few years (and two cars) ago. I can't imagine that it was a fuel pump, seeing as how my friend repaired my car in the dorm parking lot in about a 1/2 hour!

I don't know a lot about cars so it would probably be better to follow someone else's advice. Best of luck in any event! I hope it isn't an expensive repair!
 

·
Registered
Joined
·
97 Posts
Discussion Starter #13
ok, i'm going to keep bugging everyone. When the car goes into safe mode, what happens? Does the motor just retard or does the fuel pump cut out?

Whats the deal with the screaming demon coil pack? Anyone have this? Is it good for our cars? I know the kit comes with the coil and the 10mm spark plug wires so i could eliminate two of my problems at once.

Thanks for all the input guys.
 

·
Registered
Joined
·
3,861 Posts
read ur manual about safe mode. details are nice :) as for the screamin... id skip it... better gas mileage has been reported... no power. dont need the larger gap, personally ud be better off going with fr wires and autolite dubs.
 

·
Registered
Joined
·
97 Posts
Discussion Starter #17
You know I'd be more than happy to bug you if i had yahoo messanger [;)]

I know i should get it checked out, but i'm very short on time. I don't have a day off till friday and i can't wait till then to get things fixed. Everything seems to be pointing in the direction of the coil. I was kind of hoping to get some feedback on it tonight and order it in the morning before work.
 

·
Registered
Joined
·
97 Posts
Discussion Starter #19
I just got back from autozone who tested my car for free. It took like 10 seconds and the guy said that it was a bad coil that was causing so much trouble. So now i just have to wait for my coil to come from new edge. I hope they ship fast, i've never ordered from them.

Anyways, thanks for the help boys and girls! [:)]
 
1 - 19 of 19 Posts
Top