Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
104 Posts
Discussion Starter #1
Hey guys, ok so here's some background info. I have had the car for roughly 3 years, put 35k on it since then, so I'm up to 69k. Ever since I got it, it has died randomly. Less than ten times total but Sunday it died twice. Ac wasn't on and it was in the low 90s. First time I pulled off the road to talk to my girlfriends dad, and it died when I got in park. About ten minutes later I pulled into a lot and it died right when I put it in park, then I started it back up and it started real easy. Today I drove about 15 miles on the highway with ac and it just wasnt cooling off. It was 95ish today. All the sudden I smelled a burning smell and my car started sounding "mad" I don't know how to explain it. I turned the ac off and let it rest. Drove back about 10 miles with ac on low. Girlfriends sisters baby was in the car I didn't wanna cook her. Got her home and left with just windows down. And there was that smell again. By the time I got to my house I thought it was gonna blow. I checked my oil and antifreeze both are good. Any tips? Water pump maybe?
 

·
Registered
Joined
·
21 Posts
Update: the sound seems to be coming from the alt
Could be many things but a bad earth connection seems likely to me.

A bad alternator would defiantly cause this problem but you should see a battery light flash up on the dash to warn you that its not functioning. If the alternator was the problem though it should of completely packed up by now especial if you have had this problem since day 1 of owning the car and travelled all of those miles!

I would check for loose connections possibly at the alternator but check all the main earth cables. I cannot advice too much as I am new to fords, but in the past had similar problems that were all down to bad connections.

I am a little unsure of your description though to be honest.

Is the car over heating? all of the time? or just when you get the problem?

I am guessing your car is automatic as you say when its in park? or am I getting it wrong and your saying when you park?
 

·
Registered
Joined
·
104 Posts
Discussion Starter #4 (Edited)
Well my grandpa checked it out (he is really good with this stuff) and he said the alt bearing is about dead. He took it down to the farm and they are putting a new one in. He said the burning smell smells like an electrical burn so yeah... I suck at this stuff lol. Hopefully this fixes it.
 

·
Registered
Joined
·
21 Posts
Well my grandpa checked it out (he is really good with this stuff) and he said the alt bearing is about dead. He took it down to the farm and they are putting a new one in. He said the burning smell smells like an electrical burn so yeah... I suck at this stuff lol. Hopefully this fixes it,l.
Fingers crossed buddy, let us know if it cures it!
 

·
Registered
Joined
·
282 Posts
Best of luck bro
 
1 - 6 of 6 Posts
Top