Focus Fanatics Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
175 Posts
Discussion Starter · #1 ·
So the other night I was driving with my lady, and I noticed my car started to bog down a little at stop lights but kept goingg and it started doing it more to where it would almost stall anyways long story short it kept doing it and finally got to where it almost died and the check engine battery light came on everytime I stopped. It only does this at lights and when I stop so I went to pep boys today. And had them check my charging system and the alternator and battery both came up ok. Even though my far died when I rolled in the parking lot and said it was the battery again. I need help and have no idea what the problem can be pep boys said the only way to find out is drive the car till whatever is meSsed up fails. Am I really that outtta luck? Has anyone had this problem? Does anyone know what the problem may be? Please lmk zeetec manual trans btw.
 

·
Registered
Joined
·
37 Posts
my car did the same thing about 4 months ago and had the exact same thing happen where they checked everything and it was all ok but i didn't believe them so i changed the alternator anyway cause it was still the stock one and it fixed the problem. whats the year and mileage on your car? and do you know if the alternator is still stock?
 

·
Registered
Joined
·
175 Posts
Discussion Starter · #3 ·
Its a 2001 and it has 110000 and idk its new to me but ya I believe its the original alternator
 

·
Registered
Joined
·
37 Posts
change the alternator and see if it fixes the problem. but thats what it should be because when the battery light comes on its either your battery or alternator
 

·
Registered
Joined
·
37 Posts
i bought a used one incase it didnt fix the problem so basically i'm waiting for it to happen again. i paid 40 for a used one from a junkyard and online u can find them from 80-100. autozone there like 79.99
 

·
Registered
Joined
·
18 Posts
Actually that guys right i work at Napa and we have like five options on alternators and the cheapest cash customer price for one is 185.00 all the way up to 900 for a Bosch and I was wondering why and still have yet to find out why it is so marked up but anyway thanks for the answer cause my car has been doing the same thing and its an 01 with 71,000 and I’m almost positive it’s the original and I’ve been doing everything in these forums to get it to work like the fuel filter PCV and all sorts of random shit that it really could have been and never took notice to it having anything to do with the light coming on cause when I got the car it had glow gauges installed and I thought from the looks of the messed up wiring going on with that it was doing something to the light and just making it come on and off and here the light actually was behind the problem with my idle so thanks again man .
 

·
Registered
Joined
·
18 Posts
was actually going to tell you to check your pcv and lines and check your fuel filter cause after i changed my alt it got rid of the light but was still running rough and was stalling here and there so i changed the pcv thing runs like new again
 
1 - 12 of 12 Posts
Top