Focus Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Well guys, I got a focus, not really all too familiar with the motor on these at all...it overheats with coolant leaking, usually when it gets driven but not in idle too bad. Are there any common issues known for these 16V Zetecs? It's a 2001 5 speed, good solid car, just some coolant issues, and a check engine light. Which I think is possibly an O2 sensor, I still need to get it scanned, took her out for a spin tonight and coolant was all over the hood inside and engine, I know the water pump is f**Ed as well, however there is a leaking on the right hand side as well, where it looks be the hoses go in...
 

·
FF Cleaning Squad
Joined
·
11,959 Posts
Moved to technical chat you should get more help here.

Jon
 

·
Registered
Joined
·
22 Posts
Discussion Starter #4
No one? HOw bad is replacing the waterpump on these? Engine Bay looks pretty tight.. replacing tstat housing tstat, all hoses, and waterpump.
 

·
Registered
Joined
·
2,211 Posts
Can you actually see a leak at the water pump? Are you sure it's not pushing out of the overflow? Is the temperature steady when you're driving around?
 

·
Focus Hoarder
Joined
·
3,633 Posts
Please correct me if I'm wrong but isn't the water pump in a 16v 2001 Zetec buried behind the timing cover somewhere down in the middle of the motor......

I know when i fill my overflow it starts relieving itself all over my driveway and first glance from under the car its coming out of the lower timing belt cover
 
1 - 6 of 6 Posts
Top