Focus Fanatics Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I installed a Guide Turbo into a 2003 Ford Focus. After the kit was installed the car ran fine. 7 Pounds of boost no problem. I drove it for 3 days. On the 3rd day I am driving and shift into 3rd gear and the boost spiked to 10 PSI(it may have gone more). Next thing I know 4 nice new wholes in the sides of he block, and 1 piston decides it wanted to leave the motor. Complete distruction. Was able go get a complete motor with 1000 miles on it for $500 bucks. and installed it and the car is running fine. I want to put the turbo back on. Anyone have any ideas why this could have happened. So when I put it on the new motor I do not have this problem again?
 

·
Registered
Joined
·
1,091 Posts
Many motors with the Gude turbo kit have had this happened, you aren't the first. They are known for this because their kit comes with basically next to none fuel/air engine management. You'll need bigger injectors and some type of way to regular the fuel/air. Focal is going to have a field day with this thread...
 

·
Registered
Joined
·
1,666 Posts
why is it NO ONE can spell zetec right? if you have the engine and installed that gude turbo kit then you should have been under that hood enough to see ZETEC written right on the valve cover. grrr, just bugs me. dont take it personally. we arent drivin hondas here.
 

·
FF Affiliate
Joined
·
31,414 Posts
What did you have for tuning ,Or where you told like every one else thet you didnt need any below 7psi

Oh another thing there waste gate has a flaw,,IT DONT WORK PROPERLY

You i hate to say are one of MANY MANY MANY that have fallen victom to the gude

Tom
 

·
Registered
Joined
·
5,679 Posts
i would give a call to tom (iturbofocus) he might be able to help you...
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #10 ·
Yes I was told I do not need tuning below 7 psi, so I learned. If anyone else has had this problem contact me. Maybe if there are enought people, a lawsuit is in order. I am thinking of getting a new wastegate, and modifying the downpipe so it does not hang up, and using a SAFC II on the car.
 

·
Focus Addict
Joined
·
1,245 Posts
Zarelli6 said:
why is it NO ONE can spell zetec right? if you have the engine and installed that gude turbo kit then you should have been under that hood enough to see ZETEC written right on the valve cover. grrr, just bugs me. dont take it personally. we arent drivin hondas here.
I am more concerned with all the wholes caused by the guide turbo. [8]
 

·
AKA Toyotech
Joined
·
4,041 Posts
please sell that safc and get something for real tuning, that product is useless on our cars.
 

·
AKA Toyotech
Joined
·
4,041 Posts
because the ecu stays in a learning mode for one main reason. and all the other little tid bits.

what do get, for that...you already have a 70mm maf? or no...

i see your in ohio, if possible you might want to call up lidio and make the drive to get the car tuned because if you keep it this way, u won't stop blowing the motors...with the afc, where u at least able to see how lean the car was running?
 

·
Registered
Joined
·
2,022 Posts
Zarelli6 said:
why is it NO ONE can spell zetec right? if you have the engine and installed that gude turbo kit then you should have been under that hood enough to see ZETEC written right on the valve cover. grrr, just bugs me. dont take it personally. we arent drivin hondas here.
I'm with him.
 

·
Registered
Joined
·
380 Posts
i would get a better wastegate, and BOV, for managment go to www.modulardepot.com, they have a chip or an ECU flasher and they give you a base tune ($800), for injectors go to www.c-f-m.com best price on 42lb injectors and they may be able to help you with a chip too if you dont want to spend 800 on the SCT stuff from modular depot.
 

·
Registered
Joined
·
793 Posts
another victim... the saga continues...
 
1 - 20 of 23 Posts
Top