Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I was in the middle of a road trip yesterday when I was cruising at around 85mph. All the sudden I hear a loud grinding noise from the bottom driver's side and then the same noise from the bottom passanger side....right after that my guage's all go all the way to the right, then all the way to the left. My car made a "ding" and then went back to normal. There was no hesitation in the car. I don't understand what this is, can someone help? I just had the alternator replaced a month ago (for the second time, the first one they put in went bad). Also, I noticed that my lights would get bright and then go back to normal every once in awhile.....is this a sign that the alternator is bad, again? Are these two things related? HELP PLEASE!!!
 

·
Registered
Joined
·
1,067 Posts
sounds like something physically came undone in your alternator... take it back and get it looked at
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Ok, so I just got my car back from the shop and they said that they checked the alternator and everything was fine. So should I assume that they just don't want to admit that they didn't tighten stuff enough last time, and that they fixed it this time. Or should I assume that something else is wrong with my car?
 

·
Illegal Alien
Joined
·
4,586 Posts
well, did you check for your self, before taking it back to the shop? I could be exactly what you are saying. Use the car for a while and see if it stoped doing it.
 
1 - 5 of 5 Posts
Top