Focus Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
1,395 Posts
Discussion Starter #1
has anyone else had a problem with the F2 CAI? i don't know what's wrong, but i have a LOT more hesitation than when i had the stock intake on there. up top, it's stronger, but i've lost a lot of bottom-end torque. the new TB wasn't even wnough to get rid of it. i've checked for leaks time and again, and i keep hearing suction, but can't figure out where it's coming from. i more or less re-installed it, tightend down all the clamps as much as i could, and i still don't get it. is that suction sound an indicaiton of a leak? is this normal? i've done everything but start spraying my intake with starting fluid.

sorry for the rant!
 

·
Registered
Joined
·
1,567 Posts
I get a bit of a "turbo" effect in 2nd gear, where it seems as if i have turbo lag. Other than that, nope. I've had mine on since Christmas and it defintley makes the car quicker thorughout most of the powerband. Maybe since its so big it needs a few seconds to get air flow going as compared to the tiny stock intake system. I wouldn't go back to stock for anything in the world though.
 

·
Registered
Joined
·
460 Posts
my 95 mustang did that with my CAI after I had it on for a while. what i did was buy a can of actual throttlebody cleaner and a can of electrical terminal cleaner. Spray the element inside the MAF senesor with the electric terminal cleaner. and spray the throttlebody cleaner in your intake manifold. I swear it felt like that added some 10-20hp of verry low end torque. i had to keep doing it ever 2 weeks i dont know why. thinking on it now maybe it was my airfilter that wasnt filtering right and that dirtied up my sensor quickly. the suction sound could be your airfilter taking in all that air but your engine not taking in all of it due to the improper intake readings.
 

·
Registered
Joined
·
409 Posts
I was going to say, it sounds just like the issues we have on Rangers since the MAF is right at the air filter. The filter oil saturates the MAF wires and causes off-idle stumble and rough idle. THat's the problem with stubby intakes...
 

·
Registered
Joined
·
1,395 Posts
Discussion Starter #6
i dunno bout the K&N cai, but the filter on mine is down in the fender where the stock airbox used to be
 

·
Registered
Joined
·
367 Posts
Shadowrunner said:
has anyone else had a problem with the F2 CAI? i don't know what's wrong, but i have a LOT more hesitation than when i had the stock intake on there. up top, it's stronger, but i've lost a lot of bottom-end torque. the new TB wasn't even wnough to get rid of it. i've checked for leaks time and again, and i keep hearing suction, but can't figure out where it's coming from. i more or less re-installed it, tightend down all the clamps as much as i could, and i still don't get it. is that suction sound an indicaiton of a leak? is this normal? i've done everything but start spraying my intake with starting fluid.

sorry for the rant!

I don't know why you are experiencing hesitation and loss of torque but the sound is totally normal. You have removed the stock intake which is designed from the ground up to quite the engine. The sound you are hearing is simply the throttle plate opening and air rushing past it into the intake manifold. If you can have someone blip the throttle while you listen with the hood up you can clearly hear this. The only advice I can give is to try a new CAI. I have the Steeda Short Ram and have had no problems so far.

Good luck I hope you solve your issue.
 

·
Registered
Joined
·
1,395 Posts
Discussion Starter #8
i don't have monvey to blow on the a newcai.... maybe the short ramn if the f2 fi;ter wil fit on the maf tub e. i'm dfrinunk ads shit right now, sorr for the miss typoes.
 
1 - 8 of 8 Posts
Top