Focus Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have a 2003 ford focus zx3 hatchback. Fuse #30 keeps blowing.I have not parking lights, tag light, and no interior lights. Replaced it and it would work fine and then blow again. I zlready replaced the headlight switch. Checked the wire bundle between the hatch and the car and there are no damaged wires. I cant seem to figure out what is wrong with it. Any help would greatly be appreciated.

[???:)][:(!]
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
There are not actually tag lights. The car was used for racing before we bought it so they took out the tag light assembly.
 

·
Registered
2004 Focus Wagon, Zetec DOHC, Auto
Joined
·
1,426 Posts
If the wiring has been modified, there is the possibility that they left an uninsulated wire dangling somewhere that is occasionally shorting out.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #5
Took everything off and still could not find any messed up wirers. Noticed that when I try to get up to speed quickly the fuse blows. As long as I take it easy the fuse last longer. Put in a circuit beaker fuse so I'm hoping this helps out while I try to find the problem. If y'all can think of anything else that could help I would greatly appreciate it.
 

·
C2H5OH
Joined
·
11,867 Posts
You know how a pendulum works?

There is a bare wire grounding out somewhere.
 

·
DTC P0606
Joined
·
3,364 Posts
Fuse 30 is the always hot power supply to the lighting switch. It then goes from the switch to other fused lighting circuits via the interior fuse box. If the other circuits were causing problems, I suspect the other lighting fuses would blow first.
How about checking the orange/black wire that goes from fuse 30 to the lighting switch for chafes and unintended grounds and also the back of the interior fuse box for possible loose wires (that may touch the metal fusebox casing, for example)? You could possibly run a second wire to bypass that circuit as a test.
 

·
Registered
Joined
·
3,022 Posts
Escorts and Focuses were known for hatch and trunk wiring issues. I had a zx2 that the previous owner put a larger fuse in place and the trunk was smoldering one day. Sure enough all the wiring was corroded. Got a $60 harness from the dealer and it was fine beyond when I sold it.
 
1 - 8 of 8 Posts
Top