Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I am wondering if anyone here has had an issue with a faulty Fuel Tank Pressure Sensor (code P0451) and what you did about it. I know where that sensor is located and if needs to be changed is rather costly for labour. I am going to change the fuel cap to see if that helps it any but wondered if this is a common problem with these cars. I have a 2009 Ford Focus SES.
 

·
Registered
Joined
·
426 Posts
on my 01 wagon, the bad gas cap lite has been on for 4 years, i went nuts, trying to find the problem. ,there are about 10 places that can leak air and send the lite on, saying bad cap. i just covered the lite, the only real problem is it also lites the check engine lite,,, now if i have something else go wrong i wont know;; hey;[???:)] mabey thats a good thing[twothumbs] by the way car28, after you change the sensor, take the bat. cable off to reset,, it it stays of you got it, if it comes back on,no
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Thanks for the response, the code that came up does not say gas cap but I thought I would try it anyway to see if it did anything. It is apparently the sensor that is on the top of the gas tank however after reading more on this, there are also some other things too that it could be. So as long as the car is running okay I will continue to see if I can pin point it better before getting anything fixed. Thanks for the info.
 

·
Registered
Joined
·
285 Posts
Thanks for the response, the code that came up does not say gas cap but I thought I would try it anyway to see if it did anything. It is apparently the sensor that is on the top of the gas tank however after reading more on this, there are also some other things too that it could be. So as long as the car is running okay I will continue to see if I can pin point it better before getting anything fixed. Thanks for the info.
Just a thought> Check to the fuel filler tube....this will cause a check engine light not sure about your year of vehicle but on mine there is a hose that fits to the fuel filler tube to the tank that was cracked...because of that, it failed smog here in CA....$30 to fix!
 
1 - 5 of 5 Posts
Top