Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I am having a little trouble figuring out what is going on with my car. When I get on it in high boost, randomly the car just shuts down like a rev limiter or traction control is activated. Traction control is off, usually happens at about 5-6k rpm. Would this be a fuel cut, Misfire or bigger problem?
Current Modifications are:

  • [*]The BEAST intercooler(Problem was before bigger intercooler)
    [*]NGK one step colder plugs
    [*]MBRP 3" intake tube
    [*]AEM(K&N) Filter
    [*]MBRP 3" Catless Downpipe
    [*]MBRP 3" Catback Exhaust
    [*]Cobb AP V3(Custom tune by Troy Ramsey @ Panda Motorworks)93 Octane (Running Currently) & e30 tune ran on occasion.
    [*]Torque Solutions Throttle Body Spacer
    [*]Stock Turbo
Spark plugs are gapped to specs, gotten firmware update on the ECU because car is a 2015 and had a minor recall for rough idle. The custom tune has been ran by many in my area and have experienced no problems.

Thanks for your time and consideration for whoever responds.
 

·
Registered
Joined
·
2 Posts
I am having a little trouble figuring out what is going on with my car. When I get on it in high boost, randomly the car just shuts down like a rev limiter or traction control is activated. Traction control is off, usually happens at about 5-6k rpm. Would this be a fuel cut, Misfire or bigger problem?
Current Modifications are:

  • [*]The BEAST intercooler(Problem was before bigger intercooler)
    [*]NGK one step colder plugs
    [*]MBRP 3" intake tube
    [*]AEM(K&N) Filter
    [*]MBRP 3" Catless Downpipe
    [*]MBRP 3" Catback Exhaust
    [*]Cobb AP V3(Custom tune by Troy Ramsey @ Panda Motorworks)93 Octane (Running Currently) & e30 tune ran on occasion.
    [*]Torque Solutions Throttle Body Spacer
    [*]Stock Turbo
Spark plugs are gapped to specs, gotten firmware update on the ECU because car is a 2015 and had a minor recall for rough idle. The custom tune has been ran by many in my area and have experienced no problems.

Thanks for your time and consideration for whoever responds.
Did you find the problem by chance?
 

·
Registered
Joined
·
1 Posts
PLEASE LET ME KNOW IF YOU FOUND A SOLUTION! My car started doing this tonight right after i installed the Stage 1 91 OCT OTS map for my COBB AP
 
1 - 5 of 5 Posts
Top