Focus Fanatics Forum banner
41 - 60 of 79 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #42 ·
The smooth side is on the idler and water pump. So, I'm guessing it's a bad water pump or a stuck thermostat..can't decide which one to replace since I'm still not able to pick up a code
 

·
Registered
2004 ZX3 SVT EE 160k miles. 2004 ZX3 SVT 189k miles
Joined
·
3,301 Posts
The smooth side is on the idler and water pump. So, I'm guessing it's a bad water pump or a stuck thermostat..can't decide which one to replace since I'm still not able to pick up a code
The thermostat will be the easiest to change and usually the first one to go bad of the two. What I would do first.
 

·
Registered
Joined
·
1,686 Posts
The smooth side is on the idler and water pump. So, I'm guessing it's a bad water pump or a stuck thermostat..can't decide which one to replace since I'm still not able to pick up a code
Thermostat is cheaper, easier, and more likely to be a failure point. I'd start there first before doing the water pump.
 

·
Registered
2004 ZX3 SVT EE 160k miles. 2004 ZX3 SVT 189k miles
Joined
·
3,301 Posts
Only times I have ever had a code for the thermostat it was the p0128, coolant not reaching temperature, thermostat stuck open.
 

·
Registered
2004 ZX3 SVT EE 160k miles. 2004 ZX3 SVT 189k miles
Joined
·
3,301 Posts
10-4, 'ppreciate yall help. I'll let yall know how that goes
I normally go through the passenger side headlight opening to replace the thermostat on duratecs. Never tried it on the 08 and up.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #50 ·
I normally go through the passenger side headlight opening to replace the thermostat on duratecs. Never tried it on the 08 and up.
Yes sir. That's how I did the power steering pump as well. So, I just replace the thermostat and it is still overheating
 

·
Registered
2004 ZX3 SVT EE 160k miles. 2004 ZX3 SVT 189k miles
Joined
·
3,301 Posts
Yes sir. That's how I did the power steering pump as well. So, I just replace the thermostat and it is still overheating
The gauge is going up or it is spewing coolant? Are the fans running?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #52 ·
Are y'all referring the water pump for the clutch fan or the coolant pump pulley?
 

·
Registered
Joined
·
623 Posts
the fan on your radiator. that can overheat the system if not running although takes a little longer to overheat.
 

·
Registered
Joined
·
623 Posts
Is the radiator fan kicking on as the car heats up?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #58 ·
Well, I just replace the Coolent Pump Pulley, but it did not solve this overheating issues. The radiator fan clutch is functioning properly as far as I'm concerned. Not sure what else it could be
 

·
Registered
2004 ZX3 SVT EE 160k miles. 2004 ZX3 SVT 189k miles
Joined
·
3,301 Posts
Well, I just replace the Coolent Pump Pulley, but it did not solve this overheating issues. The radiator fan clutch is functioning properly as far as I'm concerned. Not sure what else it could be
There is no radiator fan clutch and why would you think a pulley could make it overheat?
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #60 ·
I've heard that the propeller inside of it could had came loose for some reason. It was either the thermostat, coolent pump pulley, or the radiator. The hoses and everything else looks fine. No sign of leaks
 
41 - 60 of 79 Posts
Top