Focus Fanatics Forum banner

1 - 20 of 25 Posts

·
Registered
Joined
·
119 Posts
Discussion Starter #1
I recently installed the FRPP suspension onto my 07 focus zx5. It seems like the rear is lower then the front or does the front need time to settle more??
 

·
Registered
Joined
·
1,073 Posts
it just needs time to settle. I know a few guys that have done this and it's a really good set up.

Just sit back, relax, and enjoy the madness!!!!!!!! HAHAHAHA!!!!!!!!!!!!!
 

·
Registered
Joined
·
119 Posts
Discussion Starter #3
Haha thanks, i just got a alignment today to thank god. My car was goin all over the damn road
 

·
Registered
Joined
·
1,073 Posts
Yea, alignments are something commonly overlooked. They can really help your stance.

Oh, and with those wheels, I'd get a spacer kit. If you do a drop and it's not to low, putting wheel spacers on gives your car the ultimate mean look.

Happy tuning!
 

·
Registered
Joined
·
3,368 Posts
Hmmm. I also have the FRPP kit (springs and struts) and I did not have to let it 'settle'. Car is flat front to back from day 1.
 

·
soon to be turbo!
Joined
·
5,728 Posts
Ya when i installed my roush springs an koni shocks/struts combo the back was lower fo some time then i intalled the SPC upper control arm an corrected the camber then it looked normal.
 

·
Registered
Joined
·
3,368 Posts
Ya when i installed my roush springs an koni shocks/struts combo the back was lower fo some time then i intalled the SPC upper control arm an corrected the camber then it looked normal.
Ahhh! Otay! I had my camber pretty much correct from the get-go. I had the SPF upper control arms installed with the rest of the suspension.
 

·
Registered
Joined
·
119 Posts
Discussion Starter #8
whats a SPF upper control arm? Im gonna give a couple weeks before i decide to do anything. Plus is seems like my back wheels sit like / \ not that drastic but you get the idea. I did the install myself so is there something i did wrong? should i loosen the top nut of the rear damper? its pretty tight
 

·
Registered
Joined
·
3,368 Posts
whats a SPF upper control arm? Im gonna give a couple weeks before i decide to do anything. Plus is seems like my back wheels sit like / \ not that drastic but you get the idea. I did the install myself so is there something i did wrong? should i loosen the top nut of the rear damper? its pretty tight
Go to MASSIVE: https://ssl.perfora.net/www.massive...nid=1547868062674ae/shopdata/index.shopscript
Under Focus/suspension (see pic)



These are nice! I have them and I think Geezer also said he has them.
No, don't think you did anything wrong. The damper nut won't affect your camber. BUT! you did NOT tighten everything until the car was on the ground yes? That's very important.
 

Attachments

·
Registered
Joined
·
119 Posts
Discussion Starter #10
I tightend everything on top once the car was on the ground. I tighten everything down low while it was up
 

·
Registered
Joined
·
3,368 Posts
Oooo! That's not right. Ya'know, I would have sworn someone else had a thread about there car not sitting level, and they found the problem I thought...but I cannot recall where it was. But I don't think yours is a camber or 'settling' issue. that is to much.
 

·
Registered
Joined
·
3,368 Posts
I went searching and came up scratch. As a starting point. Did you read and follow the Ford installation instructions? (with exception noted about tightening the bolts).
From the pic of the rear suspension. It looks like the springs are correct, but the rear sway endlinks look to be overtightened. Note: I am using a photo editor to zoom in on them so what I see and what is real may not be in agreement. You did replace the struts yes? Are you sure the tops seats are properly in the center mount hole with all four 'ears' showing? If that is OK then about the only thing left is loosening and re-torqueing the bolts with the car load on the suspension. Maybe someone else has an idea?
ADD: inspect lower spring seat. The drainhole must show just the end of the spring. Spring did not move on you maybe and is no longer seated correctly?
 

·
Registered
Joined
·
119 Posts
Discussion Starter #17
Didnt come with any instructions. I think that i did over tight the sway bar endlinks, yes i did replace the struts, what you mean all for ears showing? i can reloosen an re torque, but would i need a new alignment for the rear.?
 

·
Registered
Joined
·
3,368 Posts
Luckily, we have the same car, so I can describe this well. Rear upper shock mount (see pic). There are 4 'ears' or tabs that are part of the rear shock upper mount. These tabs extend upward through the mounting hole. Its very easy to get the tabs 'bent over' so that there not through the hole, thus the shock is not seated correctly. When the shop did mine they managed to bend two of the tabs on the drivers side and I had to loosen the shock and dig them out there. However, that would not cause your listing problem. If you lossen and re-torque your bolts, and the car settles to level, then ya, you have to get it realigned. There is a sticky btw that has the Ford installation instructions. You should get that and compare with how you installed. Maybe give you an "AhhHaaa!" moment. [;)]
 

Attachments

·
Registered
Joined
·
119 Posts
Discussion Starter #19
This is how i installed the rear damper kit and springs.
1.removed LCA bolt and lowered spring out.
2.Removed old damper from bottom to top
3. Put in new damper top then bottom.
4.Put in new spring with boots
4.Raised LCA with jack and got LCA in alignment to put the bolt in and tightend.
5.Put the weight of the car on the suspension and tightend up top

If u can show me the link for the FRPP installation instructions that would be great
 

·
has a screw loose
Joined
·
9,927 Posts
I just did this install on my 07 Sedan last week and I went ahead and bought some rear camber bolts just in case something on my rear might have been a little off . And sure enough they ended up having to use the bolts to get my rear tires to straighten out ...

I also installed a new front and rear sway bars and you can tell a world of difference since mine didn't originally didn't have any ...

Ohhh and I'm riding on 18"s and if I hit a bump pretty hard I do have rubbing issues and if I have people in the back and hit a bump I have rubbing but not for very long ..

Also my alignment was done with a new laser and mirrors set up so I hope that everything stays good for a while . :)
 
1 - 20 of 25 Posts
Top