Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
370 Posts
Discussion Starter #1
well ive noticed latley that my car has a pretty bad vibration while cruising down the street, as i got under my car to pull the filter off to clean it i looked around just to see if anything had changed and low an behold i saw the link that goes from the upper link on the strut to the sway bar link was broken, it looks like the bushing around the ball stud has come apart and the ball stud has popped out of the link, i wish i had pictures then it would be much easier for yall to understand im sure. man im sick of all this shit braking, ive nly had the car back for 2 week from it being at ford for 2 freaking months costing me $4,000 due to a wire braking on the alternator and bouncing around and caused a wire fire under the hood. im jsut wondering whats next.
 

·
Registered
Joined
·
370 Posts
Discussion Starter #3
not a single one man, i wish it would have, but i keep hearing this clunking sound from under the front end somewhere, im hoping that its just the link flopping around and not somthing else is broken.
 

·
Registered
Joined
·
301 Posts
if its the bar that has one end connected to the shock and the other connected to the sway bar,its maybe broken or its loose.i had that problem when i didnt tighten one strong enouph and everytime i turned there was a loud clunking noise and i felt it on the steering.something like if the axles were broken but alot more disturbing.if it is that.then it should only cost 22 something from ford.thats where i got mine from
 
1 - 5 of 5 Posts
Top