Focus Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
198 Posts
Discussion Starter #1
I got the car on May 13, 2011

It had 200 km's on it when it was given to me
I was informed that Ford, placed the mileage on it at their manfacturing plant.

First problem a loud banging and knocking sound, from the front end.
After a month, new left strut ordered, installed and noise 90% gone.

However minor knocking/banging sound coming from front of vehicle.
What was unusual was that the noise did not start until about 30 minutes of driving and remained there, and then disappeared the following morning when car was cold, however back after 30-60 minutes of driving again.

Needless to say many shop visits later 2 new struts, new springs etc. etc., and noise still there.

Shop foreman had hair when he started, now almost bald when I saw him on Friday, and as for Service Manager I thought he was 20-30 pounds heavier in May.

Funny thing I had noted, was that on the 2 occassions to use the defog, the windshield immediately got covered with a mist on the inside and could only be resolved by activating the air conditioner.

Needless to say I thought this was unusual however my main concern was the continual knocking sound.

Well on Wednesday the shop foreman was lying on the engine, while the service manager slowly drove the car through the parking lot attempting to locate the cause of the noise, needless to say they couldn't, however when examining the bottom of the windshield they observed mold during the entire length of the windshield.

Examination reveals that the windshield was delaminating along the entire bottom of the windshield and now mold was growing between the glass and the metal that supports the bottom windshield.

I guess this explains the reason for the moisture when ever I set the car interior to defog only.

So now I await a new windshield from ford and the cause of my noise, ???

the saga continues.....
 

·
Registered
Joined
·
4,475 Posts
I think you should start a discussion with the Ford representative about replacing your car.
If they cannot fix it to be as new, then you should not be stuck with a 'problem car Ford had screwed around with.
You have a great case for a full refund IMO.
So I am certain Ford knows this too.
THEY screwed up your car, they owe you.
 

·
Registered
Joined
·
2,654 Posts
+1, Elizabeth is totally right.
 

·
Registered
Joined
·
1,153 Posts
Either fight them or get the windshield replaced, the car cleaned. You aren't sick from the mold (at least I hope) so no need to demand a NEW car just for that. It probably won't happen anyways as the mold would not have spread and would would be able to clean it up.

Also, I wonder if the windshield delaminating and separating from the metal or whatever is the noise you are hearing? It could be rattling (glass to metal contact). I had a friend with an 07 Mustang who had his windshield replaced, similar noise appeared to what you are describing, ended up being a poor install on the windshield and got it replaced again. Sound gone. :) I hope this helps and could be a solution since they have to take the original off to at least clean the mold out of the car and reinstall it.
 

·
Registered
Joined
·
103 Posts
200 km on the odometer is a bit odd. I don't think I've ever seen a vehicle with that many on the odometer unless it was a dealer trade. Even if "Ford" put those miles on it, there should have been some sort of decal on the rear window stating that they subjected your vehicle to some tests for x number of kms/miles.

If you're going to escalate this, you need to crack open the owner's manual and get up to speed on how Ford of Canada handles disputes. It's a bit different up here versus the US in how things get resolved. Right now, the dealership appears to be attempting to resolve your concerns. The final resort is usually CANVAP (vehicle arbitration), and/or maybe something that your provincial government might have in terms of mediation.
 

·
Registered
Joined
·
936 Posts
OP, can you better describe the noise? I got a strange noise last night after about 45 mins of driving, it sounded like a shuttering/whine. Seems the whine is there alot more, but only after 30 mins of driving or more.
 

·
Registered
Joined
·
198 Posts
Discussion Starter #8
the noise is similar to a metal pipe rattling around. When I was restoring a 86 Fiero the air conditioning line were not secured and they would rattle against the body parts, this noise is identical, however different car but almost exact same noise.

It makes the same noise regardless of engine on or off, and just enough to drive you crazy as it is continual once car appears to be fully warmed up.
 
1 - 8 of 8 Posts
Top