Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
So a Quick question, and its probably really stupid. Any way. Ive noticed this creak coming from the front of my car when ever I go over the bump at the end of my drive way. Is it the suspension or something else? Ive got a 2.3 Duratec with ATX and 78,000 miles. So I was thinking it needs new springs maybe? IDK
 

·
Registered
Joined
·
1,036 Posts
Sounds like strut bearings. They're plastic and where out. i had to do them on my old ZX3 at 50,000 miles also if you are lowered they seem to where quicker.
 

·
Registered
Joined
·
25,621 Posts
sway bar end links. Lube them with some light spray oil and see if the noise goes away for a little while... If it does , get the Moog aftermarket ones, they have grease fittings on them.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #4
Thanks guys sound like next weekends project. How much are the moogs and where can I get them?
 

·
Registered
Joined
·
1,036 Posts
I got mine form carquest for the rears but I'm sure they can get the fronts as well.
 

·
Registered
Joined
·
897 Posts
creaks over bumps= sway bar end links. $30 a piece online or from a local store. As stated moog are the best on the market for aftermarket replacement. Replaced mine after i had the creaking noises and no more problems
 

·
Registered
Joined
·
672 Posts
sway bar end links. Lube them with some light spray oil and see if the noise goes away for a little while... If it does , get the Moog aftermarket ones, they have grease fittings on them.
You have to pull the rubber boot back a bit, then spray lube in. Use an oil lube, not wd40. This works for about 6 months. but it works
 
1 - 7 of 7 Posts
Top