Focus Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hello there everyone,

I have a 2001 Ford Focus DOHC ZETEC. It has had this damned engine light on for too long now. It is throwing codes for TPS voltage input low, and fuel air metering issues. I have read tons and tons of articles on this now and have come to the conclusion that i need serious help.

My first steps of action to repair this were clean/check all wiring, grounds, etc. My volt meter says it is putting out the correct voltage at idle, and at high throttle. I tried buying a tps from the auto store, horrible results it felt like a semi was rear ending me everytime it shifted into 1st. I then tried going to the junkyard and snagging a few right from other foci, still no luck. It shifted worse and the random spikes in rpms were worse.

I then tried just resetting the battery hoping it would solve it. Well, resetting it does indeed get rid of the issue...up until the computer is set again after its driving cycle then the lights back on again and its shifting awful,etc.

I have actually made the light go out for almost 200 miles before it came back on, in which it ran perfect. I have noticed also that the light seems to be triggered especially by coming to a hard braking stop from a speed 40<.

Today i went to some Ford dealerships to see whats up, they told me i need to replace the whole entire TB assembly $320, and the harness another $50. Now...i could understand this if i had a non servicable tps BUT. I can easily remove the tps, service it, and everything. What in the world would a new TB and harness solve?

PlEASE, ANYONE WHO CAN HELP ME WITH THIS PLEASE CHIME IN. I have looked on Fords website and i have found the OEM TPS but there are too many variations in the different part numbers for me to figure out which one to buy.

Thanks so much in advance!
 

·
Premium Member
Joined
·
21,250 Posts
Today i went to some Ford dealerships to see whats up, they told me i need to replace the whole entire TB assembly $320, and the harness another $50. Now...i could understand this if i had a non servicable tps BUT. I can easily remove the tps, service it, and everything. What in the world would a new TB and harness solve?
That's an issue with the early Foci. Go to a parts store, and they give you a part that won't work right. I can't remember exactly why this is, but they were telling you the truth. If you want it to work right, you'll need to get the TB and harness from Ford.

Now, we can help you if you want to order it from a dealer that does business through this site. Look up Tousley Ford online, call and ask for Steve in parts, tell him that you were recommended by FF. He will give you a great deal that--- as a guess--- will be about half of what your dealer wanted.

That will fix your problem. I've seen this before, but I can't remember all the tech behind it. Maybe someone who has had this problem will chime in.
 

·
Premium Member
Joined
·
44,595 Posts
X2 - Whynot's Advice is generally spot on....

And Steve is REALLY helpful....
 

·
Premium Member
Joined
·
44,595 Posts
Different Engine, Different part.....

Check Steve's Prices - O'Reilly's Might be MORE expensive....
 

·
Registered
Joined
·
10 Posts
Discussion Starter #7
Thanks so much for the help guys, just doing a quick search through Tousley Ford onlines parts i was able to find the TB and harness for almost $190 cheaper! Does anyone know how hard it is to install this new harness?.. Or should i have someone do it?

Thanks!
 
1 - 7 of 7 Posts
Top