Focus Fanatics Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter · #1 ·
When I first got my 2012 Ford Focus Titanium I was having problems like the rest of everybody. Upon talking with the dealership I found out that sometimes the SD card can get screwy with the system if you put the card in before registering with syncmyride.com. I don't know how viable this information is or if even it's true but it seems after a quick reboot of my cars MyFord Touch I no longer had any problems.
 

·
Banned
Joined
·
363 Posts
When I first got my 2012 Ford Focus Titanium I was having problems like the rest of everybody. Upon talking with the dealership I found out that sometimes the SD card can get screwy with the system if you put the card in before registering with syncmyride.com. I don't know how viable this information is or if even it's true but it seems after a quick reboot of my cars MyFord Touch I no longer had any problems.
Total bullshit. There is no tie to syncmyride and the SD based nav system.

TDI won't work until you register but that is a completely different animal.
 

·
Banned
Joined
·
571 Posts
It's like Ctrl+Alt+Del, only with the parts of the car. Here's how you do it: hold down the brake pedal while simultaneously depressing the on/off switch for the cruise control. Then, while holding these down, open the glovebox. That will force your car to reboot.
[8D]
 

·
Registered
Joined
·
788 Posts
How do you force a reboot of the MFT? I know there is a combination of buttons to hit, but don't know what it is
TitaniumFred is just yanking your chain. Reboot the system by pulling fuse 67 and leaving it out for 5 minutes. This has been discussed quite a lot already. A suggestion is to do a search of the forum or look at pages 1 and 2 for key words like MFT, USB, MyFord Touch... you get the idea.
 

·
Registered
Joined
·
179 Posts
When I first got my 2012 Ford Focus Titanium I was having problems like the rest of everybody. Upon talking with the dealership I found out that sometimes the SD card can get screwy with the system if you put the card in before registering with syncmyride.com. I don't know how viable this information is or if even it's true but it seems after a quick reboot of my cars MyFord Touch I no longer had any problems.
There is definitely a correlation between the wonky Navigation system and the MFT unit and all the problems we are dealing with, as it appears that people who have the MFT system WITHOUT Navigation are not reporting issues, or at least not as much. But, what your dealer told you is not true. I've had nothing but problems with my Navigation system since day one of ownership of my 2012 Focus Titanium. The very first day, not 35 minutes after driving off the lot, I got a "SD CARD ERROR" message on the screen, then a NO GPS error alert etc. etc. The whole system needs an overhaul and I'm still not convinced that a complete hardware overhaul/replacement will ultimately be needed to address all these problems, once and for all.
 

·
Registered
Joined
·
227 Posts
I have the factory Nav on mine and I've never had a problem with it. The only problem I had with MFT was getting my music files cleaned up and tagged properly so the media commands could be built for the voice control. Otherwise, MFT has been awesome! [driving]
 

·
Registered
Joined
·
122 Posts
TitaniumFred is just yanking your chain. Reboot the system by pulling fuse 67 and leaving it out for 5 minutes. This has been discussed quite a lot already. A suggestion is to do a search of the forum or look at pages 1 and 2 for key words like MFT, USB, MyFord Touch... you get the idea.
I left mine out for 10 minutes this morning to fix some problems and it never actually reset.

All my nav info was still there, so theres no way it reset.

The weird thing is, it does run quite a bit better (the thread I made mentioned a delay betwen songs, I now only have a 1 or 2 second delay instead of a 10 second delay).

I might try it again tomorrow, leaving it for a half hour or so. But its such a pain in the butt to get to.
 

·
Registered
Joined
·
1,878 Posts
I have the factory Nav on mine and I've never had a problem with it. The only problem I had with MFT was getting my music files cleaned up and tagged properly so the media commands could be built for the voice control. Otherwise, MFT has been awesome! [driving]
Yeah, agreed. I have Nav and I have seen a lot of mention of MFT problems more prevalent among those with Nav but I have not had these problems either. There are also a lot of people on here having problems without Nav. I just used Nav earlier today. Voiced a street address to set the route. Voice music changes the whole time I was driving along the route. The thing eventually dropped me off dead-on at my destination. My only initial problems were fixed after I cleaned up my tags but it had been fine since, sans a couple little quirks but they are by no means debilitating. I'm just not ready to buy into the Nav/MFT "enhanced" problem correlation at this point.
 

·
Registered
Joined
·
109 Posts
I can't say that I've had any stability problems related to the nav. However, I'm not happy with the low success rate I've had with sync understanding street addresses. The older sync systems where the street, city and numerical address were input separately worked better. This system doesn't seem able to comprehend full addresses half the time (often it cuts me off before I even finish saying the address).
 

·
Registered
Joined
·
1,878 Posts
I can't say that I've had any stability problems related to the nav. However, I'm not happy with the low success rate I've had with sync understanding street addresses. The older sync systems where the street, city and numerical address were input separately worked better. This system doesn't seem able to comprehend full addresses half the time (often it cuts me off before I even finish saying the address).
I personally haven't experienced these problems cchaos. Mine seems to do a good job but I don't use it all that often honestly. I have never had a full address fail, just sometimes it will offer me a list with some "similar" matches well away in different states. Don't know if that is normal or not. Either way, the one I want is always in the Line 1 spot so I don't know if it just orders them in list from closest to farthest.

When you say "low success rate", how low are you talking (approximately)?
 

·
Banned
Joined
·
571 Posts
I don't use voice for Nav, doesn't work for me. Doesn't come close to anything I'm asking for so I gave up a while back.
 

·
Registered
Joined
·
4,328 Posts
I left mine out for 10 minutes this morning to fix some problems and it never actually reset.

All my nav info was still there, so theres no way it reset.

The weird thing is, it does run quite a bit better (the thread I made mentioned a delay betwen songs, I now only have a 1 or 2 second delay instead of a 10 second delay).

I might try it again tomorrow, leaving it for a half hour or so. But its such a pain in the butt to get to.
EDIT: I pulled fuse 67 (SYNC/MFT) AND fuse 79 (NAV) and left them both out at the same time for ~10 minutes. Worked for me.
 

·
Registered
Joined
·
109 Posts
I personally haven't experienced these problems cchaos. Mine seems to do a good job but I don't use it all that often honestly. I have never had a full address fail, just sometimes it will offer me a list with some "similar" matches well away in different states. Don't know if that is normal or not. Either way, the one I want is always in the Line 1 spot so I don't know if it just orders them in list from closest to farthest.

When you say "low success rate", how low are you talking (approximately)?
Like 50% or less. It's really frustrating when it won't let you even finish saying the address before cutting you off and suggesting something you didn't say.

Manually typing in the address seems to be more reliable, but of course you have to be stopped in order to do that.

Other than that, once the destination is entered I like how the Nav system works. I just wish entering the destination wasn't so frustrating.
 

·
Registered
Joined
·
2 Posts
My Titanium with all possible options was build during the first week of August. I took delivery the last week of August. After a few days, I had the SD card error and the screen froze up a few times. Our dealer put in the latest updates and the system has performed well since then with a few minor exceptions. Had one auto-reboot. Nav works great! I like the next turn shown on the left screen. With that, I don't have to take my eyes off of the road. Sometimes takes a few minutes after startup before it will take voice commands with out a delay after pulling the switch. Part of boot process? Overall I really like MFT. Nav/Voice works much better than that on the Prius I traded in on the Titanium. I do not plan to use Sync Services. Not necessary with Nav/Sirius in my opinion.
 

·
Registered
Joined
·
182 Posts
I don't use voice for Nav, doesn't work for me. Doesn't come close to anything I'm asking for so I gave up a while back.
+1 - I've tried voice command and key entry, nothing doing. Voice command is probably because I'm not doing it right but key entry is beyond me. I had to take out my old Garmin.

Here's a funny. I've saved my home addy and it doesn't take me there. Close but not home. So I saved POI when I got home. Still no dice. Makes me question the accuracy of the Sat Nav.
 
1 - 20 of 21 Posts
Top