Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Hi my name is Jason im new here.

I have a 2002 Focus SVT and i love my car and lately iv been having problems with it starting. Afew months ago i put a clutchmasters stage 3 with aluminum flywheel in my car and after i installed it, it makes a loud, funny sound. So i called clutchmasters and the guy i talked to, jose, and what i did was walked out to my car, i had my dad start it while i held the phone by the car so he could hear it and he said "wow, il would look into it". Well he never did call back so like two weeks later i called and he said the same thing. Then i called again and from then on whenever i called them they wouldnt pick up.

What im trying to figure out is why my car is making this noise after i installed one of there clutch kits thats made for my car, you know.

So just so you know what im talking about, i made a video and put it on youtube and no one seems to know what this is.

Also its has a autozone starter, if that makes a difference, and iv replaced it several times and it does the same thing. I dont know it i can shim the starter or the flywheel to make this loud noise stop.

So if you know what it is please let me know.

http://www.youtube.com/watch?v=X9FpX2hEKuk
 

·
Registered
Joined
·
497 Posts
Sounds like the starter isn't meshing with the ring gear on the flywheel propely. What did the starter gear and ring gear look like? Any damage? Maybe you didn't properly install the kit? If it didn't make this noise before, it must be the flywheel in your kit or the worksmanship of the install. They are the only thing that's changed, bud.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
The oem flywheel and the CM flywheel looked the same when we installed it. My buddy and i installed it using his lift. Iv talked to everyone and done my research and i may just have to order a fidanza flywheel and get a new CM clutch and re-do it again and hopefully that will fix it.

Its funny how everyone that iv talked to or read up online about cluchmasters said there great and have great customer service. But i couldnt believe how they treated me like crap on the phone and just blew me off, you know. I spend upto $900 for a part that you would think they would try to some how help me out on the problem. For example, if i got a bad flywheel you would think they may help me get one that wasnt bad.

So now i gotta spend more money buying another setup altogether cuz of this.
 

·
FF PHOTOG ENTHUSIAST
Joined
·
15,097 Posts
** Moved ya into the Tech Forum.

Sorry to hear of your experience with them.

Hopefully we can help you out.

As for the starter, it does seem to be working, but I agree that the starter is probably not catching the flywheel very well.

Good luck and let us know what you find out. And hopefully some other peeps in there can chime in and help you figure it out ... and hopefully, save you money and more headache than you are already experiencing.

-Ray-
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5
I was wondering does the focus svt trans have dowel pins on the bell housing, between the engine and the trans? And if so, would it make my starter make this sound during start up?

Cuz i dont remember seeing any and if there is suppose to be then maybe this explains the noise.
 
1 - 5 of 5 Posts
Top