Focus Fanatics Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Interesting issues

car has 175k

was playing around and took her to 5000 rpm or so

the tach stop accelerating and the engine kinda paused- no additinal power but didnt cut out

the instrument gauges did their sweep when the batt is disconnected and you first start it but im still driving at speed

i was able to resume driving just fine, nothing was reset- the trip odometer was correct and all the radio stations were still saved

battery connection is good, as well as alternator- i do have a vibration in the engine bay from a worn engine mount but thats all the

gas mileage is starting to deteriorate from usual but it is winter

never had the fuel filter changed- just looking for some ideas

thanks


V
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Haven't had time just yet, just checked that batt connection was good and that the plug wires were on right

What's the best way to check for a clogged cat beside removing them, exhaust is very rusted and being held up by coat hangers - don't really wanna replace the exhaust yet unless I have to

V
 

·
Vince your Moderator
Joined
·
5,074 Posts
Check the coil pigtail for any pulled or cracked wires. If so replace it.

Then remove the coil and check it for any cracks even on the bottom of it. If so, replace it with a Motorcraft coil. Any other coil brand is crap.

Post results.
 

·
Premium Member
Joined
·
44,595 Posts
I always end up asking the 'dumb" questions...

Could it have bee 6,000 or so? There IS a rev. limiter in the system.
 

·
Premium Member
Joined
·
44,595 Posts
OK - had to get that out of the way.

Coil probs. often show up at the top first, would likely be a "rough" miss for that though.
 

·
Registered
Joined
·
167 Posts
Not really sure how to check for a clogged cat other than having it checked by an exhaust shop. Mine slowly would get worst as in the next week it would only go up to 4k rpm then slowly decreased. They also get pretty hot when mine finally wouldn't let me go over 3k rpm it was glowing red.

At this point it could be multiple things but it's worth checking especially if it has 175k on it.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #11
Semi update:

I can replicate the issue again and again- not exactly the same rpm- close tho

Between 5000 and 6000

Engine power is not affected at all but instrament cluster and radio restart and or turn off then on- the trip odometer and radio stations do not get reset but the do turn off and on

Hopefully just a loose wire in the cabin electrics and no issue with the engine

V
 

·
Registered
Joined
·
637 Posts
Remove the kick panel under the dash on bother the driver side and passenger side of the car, each side should have two flat head fasteners holding them in. Then you can check for any loose connections in the harnesses behind the panels
 
1 - 12 of 12 Posts
Top