Focus Fanatics Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hello guys,

I have a 2008 ford focus with the code P0731. The car drives normal when I accelerate hard but when I accelerate slow like city acceleration the transmission seems to get confused and shift to second gear prematurely. The trans light comes on and then all the gears start to shift wrong and I start to feel like my car is hit every time it up shift and also when downshift. I read the code and check the fluid which seem fine in level and color. Do you guys know what it could be? I have read on internet an they recommend fluid change and solenoid A and B change as well. Do you guys think that will probably fix it?.

I also have another question. There is wire housing under the air filter box that have some cables that to head light and the fog light. However, there is one connector there that is hanging with no connection. I am also wandering if there is a sensor that is disconnected that could be causing my transmission problem. I tried to look around to where the cable can reach and I cant see where goes. I am going to attach a picture here of the cable location and the connector to see if you guys probably know and can tell where it goes. Thank you so much for you help.

One the first picture I have the connector in my hand and on the second it is above the red cable hanging on top of the trans.
Conector car.jpg
car conector.jpg
 

·
Registered
Joined
·
12 Posts
Discussion Starter #2
Hi guys,

I think I found which connector that goes to. It seems that these car have a hood switch I guess to know when the hood is open or closed so that is the connector fr that.
 
1 - 2 of 2 Posts
Top