Focus Fanatics Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Anyone else have a problem with your lights (all of them) flickering at idle? I can give the car just the smallest bit of gas and the lights are steady. My ride idles around 750-800 RPM and as soon as the RPM's are over 815-825 or so the flickering is gone. Not a real problem, just kinda annoying - my 01 ZX3 did the same thing but not as noticeable.
 

·
Registered
Joined
·
76 Posts
Mine don't flicker, but the are dimmer at idle then when under throttle.
 

·
Registered
Joined
·
248 Posts
The only lights that I notice flicker are the mileage/trip odometer. I notice constantly at night.
 

·
Registered
Joined
·
34 Posts
This is a common problem on UK ST Focus's. It seems to be caused by power spikes from the alternator, and as far as ford are concerned there's nothing that can be done !! Inherant fault of the vehicle [8]
 

·
Registered
Joined
·
966 Posts
Yeah, it happens to me as well, and when I brought it to the dealer to get looked at they said it was normal for the car.
 

·
Registered
Joined
·
9 Posts
Discussion Starter #9
"normal for the car"... I love that bleedin' bit [rolleyes] we get from Ford. thanks, I think I will check the battery terminals and then just see what my service department has to say about it. I was wondering if the voltage regulator was bad as I have had similar problems with the old Vespa's I work on and it usually always is a voltage regulation issue.
 
1 - 9 of 9 Posts
Top