Focus Fanatics Forum banner

1 - 20 of 67 Posts

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #1
I know I may sound like a retard by saying this but I will and I am serious about because I am so fed up with it.

I bought my cossie TB and installed it and from the very beginning was having revving issues and the idle was funny... now that is cured, but now when I go to stop and copmpletely stop the car shakes a little like it's gonna die but then jumps right back up to normal idle. It hasn't died yet when it does that (knocks on wood) but I want to fix this before it does die. It did die once but that was right after I started it and then it died and then started it again and it was fine and I do know this had something to do with the TB but didn't have to do with the stopping and feeling like it is gonna die.

I am so fed up with this thing, it's not even funny... the check engine light came on a few days ago and when I brought it to the dealer they said it was because of the aftermarket TB but I don't think so but they could be right...

Also another problem I am having is at dead idle in neutral say in my driveway. When it is just sitting and idling, when listening, you can hear this faint thump coming from the intake... and I think this only is happening after the cossie TB and if so why? I don't know if this faint thumping every like 7 seconds is normal thats why I really need some help. I also don't know FOR SURE if the thumping happened before installed my TB but I never noticed it.

Any help is GREATLY appreciated because I am sick of this thing.
 

·
GreyRice WOoT!
Joined
·
10,786 Posts
lol yea i had same issues, you bought this new? if u did im not quite sure, but with mine i had qierd revvings and thing wa sa pain to figure out, well your TB may be shot, try getting another one. anonther thing you may have a leak, may be a hole on the tb somewhere/? the gasket isnt fully sealed? the air intake may have a hole, or isnt properly secured to tb?, also adjust your idler screw, it may be that, just turn car on and adjust it to get a decent idle. other then those i hav e NO CLUE lol sorry bro, hope u get it fixed
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #4
Everything is on right and the TB is brand new yes... although I think it may just be the idle adjustment screw... I know the car idles fine but when I go to stop and and I come top a complete stop, the cars RPM comes down and it feels like it is gonna die and then all is fine.
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #5
I think I may turn the screw just a little bit like I am kicking up the idle and maybe that will keep it from doing that.
 

·
Registered
Joined
·
3,022 Posts
throttle bodies are a bad choice for a performance mod.

ask randy at focussport and he will tell you everything you need to know why you don't want to put a throttle body on your car.
 

·
Registered
Joined
·
8,506 Posts
im having the same type of issue. look at my mods in my signature.

when i pull up to a stop light it goes down to 500RPM, and then back up to 700RPM and just stays there. i thought it might be my tach, but i went into test mode and its showing the same thing.

the thump coming from the intake i also have. if you listen closely to the exhaust you'll hear it there too, its either a small small backfire or miss-fire, probably a backfire b/c of the modifications.

i talked to walter at MM, he has heard this issue before but instead of it idling down it'll not want to idle down as fast. he said it could be a glitch in the software for the ECU, so if you took your car down to ford and had them reflash the stock program with the most up to date one, that could probably help, OR if you got a SCT excal 2 with a tune, that should take care of it. i havent done either of these things with my car yet, i know my car does it, and it does bother me, it has never died yet, but i know its a learning and modifying process. my next big mod is to get a SCT excal 2, i dont know with walter being out of the office more if im gonna get it from him, i might go with HYPNO.
 

·
Registered
Joined
·
1,797 Posts
I thought the cosworth throttlebody only worked on the cosworth intake manifold?
 

·
Registered
Joined
·
287 Posts
i had the 65mm tb with the same problem. i couldnt figure it out so i took it in, and turns out the tps broke. they are cheap plasitc, also make sure the gasket seals good. its a good mod though, put it this way the throttle is so sensitive sometimes in first in a parking lot it lerches.
 

·
Registered
Joined
·
57 Posts
wickedgreyzx3 said:
throttle bodies are a bad choice for a performance mod.

ask randy at focussport and he will tell you everything you need to know why you don't want to put a throttle body on your car.
please explain more
 

·
Registered
Joined
·
583 Posts
my car too idles funny....500RPM's at idle when i come to a stop and back up to 700. It did it since i bought it and even after i got the exhaust and CAI installed. it does bother me but it has not died on me yet?...(knock on wood) maybe its a software ECU issue or something? ohh and i have an Automatic anyway.

Johnny
 

·
Registered
Joined
·
8,506 Posts
aero_student said:
I thought the cosworth throttlebody only worked on the cosworth intake manifold?
if i remember right i read somewhere that you can bore out the stock manifold for the cossie TB to fit??
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #13
aero_student said:
I thought the cosworth throttlebody only worked on the cosworth intake manifold?
the cossie Tb fits just fine on the stock intake manifold... thats not an issue take it from someone who actually has the TB and not just word of mouth.
 

·
Retired Focus Addict
Joined
·
9,681 Posts
Discussion Starter #14
wickedgreyzx3 said:
throttle bodies are a bad choice for a performance mod.

ask randy at focussport and he will tell you everything you need to know why you don't want to put a throttle body on your car.
I talked to Ivan at Focussport... where I bought the TB and he said it's a great mod, never heard that it is a bad choice... you have to have a TB to understand that is a great mod once you get it right... I find nothing wrong except for the little flaw I am having.... overall it is GREAT mod.
 

·
Registered
Joined
·
1,145 Posts
The only difference is the Cosworth TB is 67mm instead of 65mm, not a big difference. But as for your problems, sounds weird to me....
 

·
FF Cleaning Squad
Joined
·
11,959 Posts
Sharon my car does that and its stock.

It might not be your TB.
 

·
Registered
Joined
·
23 Posts
mine has always done this. it makes me hate my car, especially with a stiff motor mount as you feel it. tuning is the only answer.
 

·
Registered
Joined
·
9,084 Posts
if you are having that many issues id ditch it.
 

·
OMGVTAK!
Joined
·
60,646 Posts
^I agree. I wish I would have kept my stock TB cause I have a love/hate relationship with my aftermarket one.
 
1 - 20 of 67 Posts
Top