Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Spin
Joined
·
2,913 Posts
Discussion Starter #1
I have installed both the FC 65mm throttle body and Steeda CAI. I have ran into problems.

After I finally got everything installed correctly (read sig), she ran great. That was this morning.
When I wanted to go on a celebratory cruise this evening, I noted at low RPM it runs like a VW bug.

I reset the ECU but barring that I don't know what is causing this or what to try next. I've done a search but this throttle body install is as far as I know pretty straight forward, same with the CAI.

Thanks for any help!
 

·
Spin
Joined
·
2,913 Posts
Discussion Starter #2
Sorry everyone, I fixed the problem. During install one of the "vacuum" lines snapped out, a quick snap back in fixed it. [8D]
 

·
all grown up
Joined
·
3,949 Posts
Good goin' Bob. How does it feel? I'm still in the process of contemplating the purchase of a FS TB. The CAI makes a helluva difference on these cars though.
 

·
Registered
Joined
·
13,065 Posts
Bob, regarding your signature, did someone tell you you didn't need the gasket?

If so, it was probably another Ze/Duratec misconversation. For clarity, Zetecs use a cardboard-looking (don't know what it is) gasket, a new TB should come with one. Duratecs need to pull the thin rubbery teal (at least mine was teal) gasket off their stock TB and put it in the corresponding groove on the new one. Also, Zetec TBs need an "automatic bracket" whereas all Duratecs regardless of tranny use the same single piece.

Glad you figured out the vacuum hose issue!
 

·
Spin
Joined
·
2,913 Posts
Discussion Starter #5
turbovation said:
Good goin' Bob. How does it feel? I'm still in the process of contemplating the purchase of a FS TB. The CAI makes a helluva difference on these cars though.
The throttle is more touchy, I have to watch that I don't step on it too hard. Though I think lightness of throttle is one of the selling points. [8D]

Lil PZEV said:
Bob, regarding your signature, did someone tell you you didn't need the gasket?

If so, it was probably another Ze/Duratec misconversation. For clarity, Zetecs use a cardboard-looking (don't know what it is) gasket, a new TB should come with one. Duratecs need to pull the thin rubbery teal (at least mine was teal) gasket off their stock TB and put it in the corresponding groove on the new one. Also, Zetec TBs need an "automatic bracket" whereas all Duratecs regardless of tranny use the same single piece.

Glad you figured out the vacuum hose issue!
No, no Ze/Duratec misconversation for me. My new TB came with no instructions for installation, so I didn't know the gasket was needed. (Normally you expect everything to come with a purchase)
 
1 - 5 of 5 Posts
Top