Focus Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
385 Posts
Discussion Starter · #1 ·
Alright im sure this issue is somehwere in a thread on here, but i dont know where. So I mise well just ask.... I keep getting where my engine wants to die and I have almost like a loss of power. If i let the RPMs get to idle it wants to die. And my lights flicker. Iv been pondering and trying to think of what it could be and from what I'v learned you guys say the coil is strong enough for the engine and everything. And the only thing I thought I read in a thread was the Big 3 ground kit thing. Any answers to what it could be?[confused]
I have an 02' SVT.
Would a tune take care of those problems?

Thanks, Ryan
 

·
FF Affiliate
Joined
·
31,175 Posts
More then likely a tune would help , if nothing else you would then have a way to datalog and see what is happening and if you go the tune from me I could make adjustments to help or look at the logs and give you ideas

Tom
 

·
Late for Dinner
Joined
·
15,332 Posts
There was also a reflash ford put out because of some of these problems.
personally tho, I'd go the tune route and hip the problem right off.
one other thing to do a quick check on it the connector hoses on the intake to head and make sure they are in good shape.
 

·
Registered
Joined
·
385 Posts
Discussion Starter · #4 ·
alright. So tune should fix most of it. Its not some mechanical problem most likely? Iv been trying for awhile to figure it out...but i need somoe good advice! hahah
Ill try to check those hoses after class tomorrow, kinda sucks since its like 20 degrees here!
 
1 - 5 of 5 Posts
Top