Focus Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi Guys,
I hope I am not crossing a red line by posting here, if so my sincere apologies - Forum is huge and I have but only a bit of time.

I really need your help,
I have a 2005 Zetec Ford Focus which in the past had the usual and well known Engine Water issues which is that water is leaking to the spark plugs. After I had this fixed by my garage for 3 times I got sick of it and took it on by myself to troubleshoot, once I swapped out the water jets I had no issues for over a year.

Yesterday I had the same symptoms once more, engine is backfiring and there is loss of power when acceleration (best I can describe it) - This morning I checked if there is water at the spark plugs and to my surprise they were bone dry.

I know I am reaching here but is there any way one of you could give me a few more angle points I could investigate before I bring it into the garage?

Thank you for your help!
 

·
Registered
Joined
·
609 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Being that the international 2005 Focus is different than the US 2005 Focus we don't have much experience with them and the issues you are having, but here is a link from a Google Search that may be of assistance: http://www.justanswer.com/uk-ford/483ao-ford-focus-zetec-washer-jets-leaked-engine.html

Hi,

Super appreciate your response, I saw the link before but thank you, the problem I am dealing with feels (As I said) exactly like the water in spark plug issue.

But they are completely dry, so that cannot be issue.

I wonder from an engineering point of view what else could cause similar symptoms.

Faulty spark plugs? Air filter etc.
 

·
Premium Member
Joined
·
44,595 Posts
Moved to General Tech. Chat for more looks.

As PC mentioned, most of us aren't familiar with your models. IIRC the zetec in that year is an equipment level in the UK & doesn't match what we know as a zetec engine. Duratec type (chain driven cams, COP ignition) is the one used for that year here, IIRC you've got different sizes of that avail..

Spark plugs & coil boots are a typical starting point on them if water/oil in the plug holes isn't a problem.
 

·
Registered
Joined
·
897 Posts
If it's the classic Zetec motor, and uses the old style spark plug coil pack that we used on the 2004 and older (2005 US speck uses separate coils that sit directly on the spark plugs) Then inspect the pig tail connector and the coil pack.
 

·
Registered
Joined
·
17,163 Posts
Water in/on plug means missing plain and simple, could be anything in ignition, coil(s), plugs themselves, boots, wires if present.
 

·
Registered
Joined
·
374 Posts
Most likely a bad coil. If it gives you a cylinder misfire code swap that cyl# coil with another and see if the code changes. That is if you have coil on plugs
 
1 - 8 of 8 Posts
Top